Sveawebpay plugin

  • Posts: 11
  • Thank you received: 0
  • Hikashop Business
3 months 2 weeks ago #307180

-- HikaShop version -- : 4.0.3
-- Joomla version -- : 3.9.6
-- PHP version -- : 7.1
-- Browser(s) name and version -- : Brave 0.63.48
-- Error-message(debug-mod must be tuned on) -- : Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 20480 bytes) in /home/xxxxx/public_html/pikadiilit.fi/libraries/src/Log/LogEntry.php on line 116

Hello

I'm getting an allowed memory exhausted error when adding a product to the cart with HTML product link.

I found out it's the Sveawebpay plugin causing this error. When I turn it off, the link works fine and I'm asked for my address and so on.

After waiting several weeks to finally get my SVEA credentials and test, now this happens.
It's really frustrating, especially since I have products waiting to be sold.

Someone please help!
Thanks in advance.

Olivier

EDIT: I'm sorry, this ended up in the wrong category apparently.

Last edit: 3 months 2 weeks ago by FollaKy.

Please Log in or Create an account to join the conversation.

  • Posts: 12131
  • Thank you received: 1672
  • MODERATOR
3 months 2 weeks ago #307181

Hello Olivier,

After waiting several weeks to finally get my SVEA credentials and test, now this happens.
It's really frustrating, especially since I have products waiting to be sold.


We can understand your frustration and we'll try to get it fix as soon as possible !

That error indicates that the memory on the page reached the limit allowed by your server.
There are several ways to solve that but we'll need more information about how to reproduce your issue and where you're getting it through some screenshots for example.

You can try to increase the memory_limit parameter of your php.ini. Try increasing it to 256M instead of 128M.
You can try to switch to the default template to see if you still have the problem or not (which would provide information on whether the problem is linked to the template or not). And you can do a similar procedure with the plugins of the groups "system" and "hikashop" by disabling them one by one to see if that helps.

Kind regards,
Mohamed.

Please Log in or Create an account to join the conversation.

  • Posts: 11
  • Thank you received: 0
  • Hikashop Business
3 months 2 weeks ago #307230

Hello Mohamed,
Thanks for replying.

My shop isn't live yet. I have 1 product in Hikashop and one html button on my front page (css class is assigned). That's basically it.

I tried increasing the memory already to 256 Mb, and it only brings more memory exhausted errors:

Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 20480 bytes) in /home/xxxxxx/public_html/pikadiilit.fi/libraries/src/Log/LogEntry.php on line 116

Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 20480 bytes) in /home/xxxxxx/public_html/pikadiilit.fi/libraries/src/Session/Session.php on line 386

Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 20480 bytes) in /home/xxxxxx/public_html/pikadiilit.fi/libraries/joomla/database/driver.php on line 1886

Increasing to 512M get's me a http 503 error. However, I don't expect creating a cart session to eat up that much memory. And I'm not going to use set memory limit to unlimited (-1) to avoid having my hoster shouting at me... Espiecially after those tryouts at 512M :-D

Changing to default Beez3 template gives the same result.

I will try disabling plugins as you suggested and will keep you updated.

Best
Olivier

Please Log in or Create an account to join the conversation.

  • Posts: 11
  • Thank you received: 0
  • Hikashop Business
3 months 2 weeks ago #307235

Hello again,

Tried to disable plugins as suggested, it only gave me 1 or more memory exhausted messages, depending on the plugin.

After looking into the sveawebpay zip, I noticed that many files are dated 2015. Are we sure this plugin is still working? It is very likely that SVEA changed something in their API. Or would that result in some other kind of error?

Thanks again for your help.
Olivier

Please Log in or Create an account to join the conversation.

  • Posts: 11
  • Thank you received: 0
  • Hikashop Business
3 months 2 weeks ago #307240

Hello once more,

Now a new error message is showing up:

Warning: Invalid argument supplied for foreach() in /home/xxxxxx/public_html/pikadiilit.fi/administrator/components/com_hikashop/classes/cart.php on line 2529

Please Log in or Create an account to join the conversation.

  • Posts: 2215
  • Thank you received: 297
  • MODERATOR
3 months 1 week ago #307247

Hello,

Ok, first of all can you switch On your Joomla Debug mode and have "Error Reporting" to maximum in order to get more informations.
Then, can you test to process some test with your sveawebpay unpublished
1. There is no more issue
=> provide your payment plugin configuration screenshot
2. That change nothing, then your issue isn't related to Sveawebpay or not directly (to be sure try with another payment plugin)
=> Url link with a step by step process to reproduce and see it by ourselves.

Awaiting news from you.
Regards

Last edit: 3 months 2 weeks ago by Philip.

Please Log in or Create an account to join the conversation.

  • Posts: 11
  • Thank you received: 0
  • Hikashop Business
3 months 1 week ago #307273

Hello Philip,

Debug mode was already On with error reporting set to maximum:


The memory exhausted errors is all that is displayed.

As I mentionned in my first post, without svewebpay enabled it works. I'm able to place orders using other plugins like collect on delivery or bank transfer. Order is created, all necessary mails are being sent.

Here is the configuration of the plugin.



Note that it's crashing with and without test and debug enabled in the plugin.

Best
Olivier

Attachments:
Last edit: 3 months 1 week ago by FollaKy.

Please Log in or Create an account to join the conversation.

  • Posts: 2215
  • Thank you received: 297
  • MODERATOR
3 months 1 week ago #307303

Hello,

Then as asked, you have to provide Url link AND a step by step process to reproduce and see it by ourselves.
Add some frontend/backend access references in order to be able to process all required tests.

Note : You have to use our Contact us form to provide these secret references, add an Url link to this thread
Awaiting news from you

Regards

Last edit: 3 months 1 week ago by Philip.

Please Log in or Create an account to join the conversation.

  • Posts: 11
  • Thank you received: 0
  • Hikashop Business
3 months 1 week ago #307331

Hi Philip,

Sorry to have misunderstood you. I assumed it was either point 1 OR point 2. My bad. ^_^
Sent you a message with credentials and step by step guide to recreate the error.
Please note that I also tested with my site online, to see if it would make a difference. It didn't.

Regards
Olivier

Please Log in or Create an account to join the conversation.

  • Posts: 2215
  • Thank you received: 297
  • MODERATOR
3 months 1 week ago #307348

Hello,

Can you add (with the same method) some ftp access, we have make some progress and have some idea, on why in your specific case there is some issue.
But before tell you more we will need to process more tests and even debug this.

Awaiting news from you, like last time publish here a new message when news elements have been provided.
Regards

Last edit: 3 months 1 week ago by Philip.

Please Log in or Create an account to join the conversation.

  • Posts: 11
  • Thank you received: 0
  • Hikashop Business
3 months 1 week ago #307373

Hello,

Good to hear you are making progress on that :-)

I just send the FTP access by contact form.

Thanks again for your help!

Please Log in or Create an account to join the conversation.

  • Posts: 2215
  • Thank you received: 297
  • MODERATOR
3 months 1 week ago #307402

Hello,

I process some test and add to your plugin some corrections, now it's your turn to check how it work because we haven't some references to process a complete order, and don't forget to give us your feedback to valid that everything work as expected.

Hope this will fit your needs.
Regards

Please Log in or Create an account to join the conversation.

  • Posts: 11
  • Thank you received: 0
  • Hikashop Business
3 months 1 week ago #307414

Hello,

Good job! Those server errors are gone!
At first it was giving some errors, but I soon figured out it was only because I had the custom field "country" disabled. I enabled it and also those errors were gone.
However I'm getting a "no payment method found" even after disabling dubug and error reporting.
I tested both sveawebpay instances separately.

Regards
Olivier

Please Log in or Create an account to join the conversation.

  • Posts: 2215
  • Thank you received: 297
  • MODERATOR
3 months 1 week ago #307491

Hello,

I was able to look a little your website and can be sure, but for us it seems that the way you configured your checkout workflow leads to issue :
1. I wasn't able to reach the payment page in your checkout workflow (second page)
2. When I reach your website I'm automatically logged as HikaShop user that prevent me to process some test
3. I was processing some setup configuration in your backend and right now for a reason or another I'm able anymore to see the HikaShop => Configuration... And I don't know why.

So far, I can only recommend you to build your website step by step, I mean make the main structure works before add some more specific features like direct log in and direct checkout.
Can you disable these specific features to get something more simple to navigate and test ?
Works on your website and process test is really difficult and so unfortunately get roots issue and help you is difficult as well.
Awaiting news from you.

Regards

Last edit: 3 months 1 week ago by Philip.

Please Log in or Create an account to join the conversation.

  • Posts: 11
  • Thank you received: 0
  • Hikashop Business
3 months 1 week ago #307509

Hello again,

Philip wrote: 1. I wasn't able to reach the payment page in your checkout workflow (second page)

That's because SVEA Webpay plugin was active.

Philip wrote: 2. When I reach your website I'm automatically logged as HikaShop user that prevent me to process some test

That's because of session cookie.

Philip wrote: 3. I was processing some setup configuration in your backend and right now for a reason or another I'm able anymore to see the HikaShop => Configuration... And I don't know why.

I'm sorry about that. I'm also working on the page and can't know for sure when you are logged in.

To me it seems now that there is a problem with my template.
My apologies for this. I will make the site more accessible and "normal" before adding modifications.

Regards
Olivier

Please Log in or Create an account to join the conversation.

Time to create page: 0.098 seconds
Powered by Kunena Forum