Hikkashop gives error

  • Posts: 23
  • Thank you received: 1
  • Hikashop Business
7 months 1 week ago #314341

-- HikaShop version -- : 4.2.2
-- Joomla version -- : 3.9.14
-- PHP version -- : 7.1.33
-- Browser(s) name and version -- : Google Chrome
-- Error-message(debug-mod must be tuned on) -- : Fatal error: require_once(): Failed opening required '/home/megiq038/staging/4/idealcheckout/includes/library.php' (include_path='/home/megiq038/staging/4/plugins/system/shlib/shl_packages//ZendFramework-1.11.7-minimal/library:.:/usr/local/php71/pear') in /home/megiq038/staging/4/plugins/hikashoppayment/idealcheckoutideal/idealcheckoutideal.php on line 15

I just created a test website (staging website) on a subdomain: staging4.megiq.com. Everything works well except the Hikkashop. See error message that you get by going to the shop (staging4.megiq.com/shop).
The backend Hikkashop in Joomla also does not work properly.
Thanx for your help.

Please Log in or Create an account to join the conversation.

  • Posts: 70198
  • Thank you received: 10513
  • MODERATOR
7 months 1 week ago #314347

Hi,

I wasn't able to get that error on your frontend. However, the error message you copy / pasted comes from the idealcheckout payment plugin which isn't a plugin we developed and we don't provide it either. So I would recommend to first check with the developer of that plugin. It seems that you're missing some pear package on your server necessary for that plugin to work properly or something like that. They should be able to tell you what you need to do.

Please Log in or Create an account to join the conversation.

  • Posts: 23
  • Thank you received: 1
  • Hikashop Business
7 months 1 week ago #314363

Oke, I will check ccIdeal.
But I also have a problem with the backend of Hikkashop (and not with ccIdeal backend!). See printscreen.
How can I solve that?

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 70198
  • Thank you received: 10513
  • MODERATOR
7 months 6 days ago #314390

Hi,

Your screenshot indicates that you have a fatal error.
But you didn't provide the bottom of the page where there fatal error message is located.
So please provide the fatal error message at the end of that page. That message will say which line of which file is causing the problem. It could actually still come from that plugin.

Please Log in or Create an account to join the conversation.

  • Posts: 23
  • Thank you received: 1
  • Hikashop Business
7 months 6 days ago #314429

Fatal error: require_once(): Failed opening required '/home/megiq038/staging/4/idealcheckout/includes/library.php' (include_path='/home/megiq038/staging/4/plugins/system/shlib/shl_packages//ZendFramework-1.11.7-minimal/library:.:/usr/local/php71/pear') in /home/megiq038/staging/4/plugins/hikashoppayment/idealcheckoutideal/idealcheckoutideal.php on line 15

And just to be sure: iDEAL Checkout is not a Hikkashop plug-in?

Please Log in or Create an account to join the conversation.

  • Posts: 70198
  • Thank you received: 10513
  • MODERATOR
7 months 6 days ago #314431

Hi,

As I supposed, it indeed comes from that plugin.
If you want to avoid the error, either disable the plugin or rename the file /plugins/hikashoppayment/idealcheckoutideal/idealcheckoutideal.php until you get an answer from the developer of the plugin.

The iDEAL Checkout plugin is a plugin for HikaShop, but it's not a plugin our company, Hikari Software has developed. It was developed by another developer to add the iDEAL payment method to HikaShop.

The following user(s) said Thank You: mlehr

Please Log in or Create an account to join the conversation.

Time to create page: 0.066 seconds
Powered by Kunena Forum