Hikashop + PHP 7.3 not compatible?

  • Posts: 3
  • Thank you received: 0
1 week 10 hours ago #316739

-- HikaShop version -- : 4.2.3
-- Joomla version -- : 3.9.16
-- PHP version -- : 7.3
-- Browser(s) name and version -- : Chrome 80.0.3987.149
-- Error-message(debug-mod must be tuned on) -- : Error: 0

Hi,

my Hikashop 4.2.3 works fine with PHP 7.2.
But when I switch to PHP 7.3 or even 7.4 is stops working - after clicking "Proceed to checkout" I get the error you can see in the attachment.

So is Hikashop not compatible with PHP 7.3 or what exactly should I do to make it work with higher version than 7.2.

Thanks.

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 68452
  • Thank you received: 10203
  • MODERATOR
1 week 10 hours ago #316741

Hi,

It is but not the legacy checkout from HikaShop 1.x and 2.x. So just turn off the "checkout legacy" setting in the HikaShop configuration in order to switch from the new checkout that was added in HikaShop 3.0.0 and it will work fine (and much better than with the old checkout).

Please Log in or Create an account to join the conversation.

Time to create page: 0.051 seconds
Powered by Kunena Forum