hikashop e falang

  • Posts: 1
  • Thank you received: 0
  • Hikashop Essential
2 weeks 1 day ago #319160

-- HikaShop version -- : v4.3.0
-- Joomla version -- : 3.9.18
-- PHP version -- : 7.3
-- Browser(s) name and version -- : chrome
-- Error-message(debug-mod must be tuned on) -- : does not work properly after updating hikashop essential and falang free

I updated falang, hikashop essential on starter because the license had expired, I bought it back and installed essential. After these updates hikashop has problems managing urls. They have changed, some give 404 error and others are not well built.

Last edit: 2 weeks 17 hours ago by sitiservice. Reason: Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in /web/htdocs/www.conservemanfuso.it/home/plugins/system/helix3/core/classes/menu.php on line 89

Please Log in or Create an account to join the conversation.

  • Posts: 69451
  • Thank you received: 10401
  • MODERATOR
1 week 6 days ago #319209

Hi,

I already replied to you by email regarding the 404 error:

Hi,
When I go to the french version of your website and then to the legumes menu ( www.conservemanfuso.it/fr/conserves-de-tomates/legumes ), I see that the links used there are the english ones.
And that's because you have the "Force canonical URLs on listings" setting activated and you've entered the english URL of the product in the "canonical URL" setting of your product, but you didn't enter the URL in that field for each language.
So you can either:
- empty the canonical URL field and set that setting to only use the canonical URL if specified
- turn off that setting so that the canonical URL is offered as a reference to search engines but not used on the listings
- fill in the canonical URL manually for each language for each product.
I've done that last option for this product: www.conservemanfuso.it/administrator/ind...roduct&task=edit&cid []=57
And now if you try to access it from your frontend, you'll see that the page of the product works in all the languages.
For a simple solution, I would recommend to turn off the "force canonical URLs on listings" setting.

That warning comes from your template. It's just because you updated your PHP but not the template (or the template needs to be fixed) and you've activated the "error reporting" or the "debug mode" setting of the Joomla configuration which display these warnings.

So please try to not post your questions in two different places. It increases the work for us.

Please Log in or Create an account to join the conversation.

Time to create page: 0.054 seconds
Powered by Kunena Forum