Hikasho setup Joomla 4 beta 2 error

  • Posts: 12
  • Thank you received: 0
1 month 1 week ago #321674

-- HikaShop version -- : 4.3.0
-- Joomla version -- : 4.0.0 beta 2
-- PHP version -- : 7.3
-- Browser(s) name and version -- : Chrome
-- Error-message(debug-mod must be tuned on) -- : 500 behavior::tooltip not found.

When I try to install Hikashop 4.3.0 on Joomla 4 beta 1/2 I get the msg "500 behavior::tooltip not found."

Hikashop version 4.3.0 works fine on Joomla alfa 12

Last edit: 1 month 1 week ago by fgonc124.

Please Log in or Create an account to join the conversation.

  • Posts: 70194
  • Thank you received: 10508
  • MODERATOR
1 month 6 days ago #321676

Hi,

That's normal. HikaShop 4.3.0, which was released a few month ago, is not yet compatible with Joomla 4 beta 2, which was released a few days ago.
We're working on supporting Joomla 4 for the next release of HikaShop.

Please Log in or Create an account to join the conversation.

  • Posts: 12
  • Thank you received: 0
1 month 6 days ago #321694

But works with Alfa 12. Is Alpha12 so diferent than Beta1 that makes this errors?

Please Log in or Create an account to join the conversation.

  • Posts: 24320
  • Thank you received: 3749
  • MODERATOR
1 month 6 days ago #321695

Hello,

Unfortunately yes, there are big differences between the Alpha 12 and the Beta 2.
Like there were major differences between the Alpha 1 and the Alpha 4, etc.
Joomla 4 is a huge project which want to change important parts in the Joomla core for the years coming, so the modifications are huge too.

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

  • Posts: 82
  • Thank you received: 1
  • Hikashop Business Hikashop Essential
1 week 2 days ago #322558

Will there be a beta of Hikashop to test with the beta of Joomla4?

I'm testing a Joomla 4b2 installation to update my own components, and so far it's been pretty nice to work with. Of course, they're kind of skimpy with the developer documentation...

Please Log in or Create an account to join the conversation.

  • Posts: 70194
  • Thank you received: 10508
  • MODERATOR
1 week 2 days ago #322560

Hi,

The next release of HikaShop, the 4.0.0 will work with Joomla 4 and Joomla 3.
A beta won't be necessary but the 4.0.0 will act as a beta on Joomla 4 as of course we won't be able to test everything.
But for Joomla 3, the 4.0.0 will work just fine like before.

We still have a few bugs left here and there but it's pretty much working fine. We're currently working on fixing the styling of the elements. We plan the release of the 4.0.0 at the beginning of September.

The following user(s) said Thank You: icomex

Please Log in or Create an account to join the conversation.

Time to create page: 0.068 seconds
Powered by Kunena Forum