Search and Filter dont work after updates

  • Posts: 2
  • Thank you received: 0
  • Hikashop Business
4 weeks 15 hours ago #331663

-- url of the page with the problem -- : www.gamedude.com.au
-- Joomla version -- : 3.9.25.
-- PHP version -- : 7.4.3
-- Browser(s) name and version -- : all

Just wondering if anyone can point me in the right direction.
Recently I updated all Joomla and Hikashop updates that were available, some were nagging me about my PHP version as well so its all updated but now the search and filter functions are broke... They work the first time but anything entered after you get the "thinking" spinning icon then nothing is changed onscreen, the filter is also the same no matter what it does not change the screen display.
The backend search still works fine only frontend, nothing was changed other than applying the updates....

Please Log in or Create an account to join the conversation.

  • Posts: 3174
  • Thank you received: 418
  • MODERATOR
4 weeks 5 hours ago #331669

Hello,

In order to progress on your subject, can you process some tests in order to better understand the context.
1. Process a test with by example ProtoStar to see if that work with a default template or change something, and make your returns about these results.
2. In order to experience your issue, provide an Url link and a step by step process to reproduce it.
3. Add your filter screenshot configuration.
4. Details the issue, especially if it's not that obvious, like by example results display products from another category while the filter designates another category.

Awaiting your elements to be able to progress on your subject.
Regards

Last edit: 4 weeks 13 hours ago by Philip.

Please Log in or Create an account to join the conversation.

  • Posts: 2
  • Thank you received: 0
  • Hikashop Business
3 weeks 6 days ago #331680

Go to the website I listed in the first post.
www.gamedude.com.au
In the search at the top type in "SSD" you will see a result..
Next search for something else like"gaming" (it does not matter the text really this is an example).
You can clearly see that the search no longer works, the only way to fix it is to click "HOME" or reload the page but it again only searches once before breaking.
This website was all working perfectly fine before applying all the updates which I am not sure what module is responsible for the search and filters or if its the upgrade to PHP which I was being nagged to do by the "extensions Update" on the backend.
Again I will mention that the search and filter works perfectly fine still on the backend,

Please Log in or Create an account to join the conversation.

  • Posts: 72738
  • Thank you received: 11090
  • MODERATOR
3 weeks 6 days ago #331709

Hi,

The issue apparently comes from an old view override which doesn't have the necessary modifications to support the new AJAX filter system we've added a few version ago in HikaShop.
I suppose that you must have a file templates/YOUR_TEMPLATE/html/com_hikashop/product/listing.php and / or a file templates/YOUR_TEMPLATE/html/com_hikashop/product/listing_div.php on your website.
Please check via FTP.
If you do, rename them, refresh the whole listing page page on your website and it should then work properly.

Please Log in or Create an account to join the conversation.

Time to create page: 0.059 seconds
Powered by Kunena Forum