Updating to Joomla 4 - plugin errors on pre-check

  • Posts: 21
  • Thank you received: 3
3 days 12 hours ago #348670

-- url of the page with the problem -- : 3dcreations.uk
-- HikaShop version -- : 4.7.0
-- Joomla version -- : 3.10

Hi ,

I am about to update my site to J4 and I have many Hikashop plugins flagged with this message:

Extension does not offer a compatible version for the selected target version of Joomla. This could mean the extension does not use the Joomla update system or the developer has not provided compatibility information for this Joomla version yet.

My site is 4.7.0 but the message at the top of this form states the latest stable version is 4.7.1 but my Hikashop about/update says it is up to date. Do I need to update my J3 site to version 4.7.1 or can I go ahead and update to J4?

My concern is that I updated to J4 on another site and it completely broke it (don't know the cause) and I had to start everything from scratch - major headache.

Thanks in advance.

Simon

Please Log in or Create an account to join the conversation.

  • Posts: 77751
  • Thank you received: 12263
  • MODERATOR
3 days 9 hours ago #348673

Hi,

All the plugins and modules included by default in HikaShop 4.7.1 (and since many releases ago) are fully compatible with Joomla 4. And they update automatically when you update HikaShop.
So you can ignore what Joomla says for them, the automated thing in Joomla just doesn't know.

Note however that all the plugins and modules compatible with HikaShop you installed next to it are not concerned by what I'm saying here.
If you installed a payment plugin from a third party developer (or even the plugins from our marketplace) and you're not up to date with it, or the plugin is not compatible with Joomla 4 yet, it's totally possible it will break HikaShop pages after the migration.
The best would be to make a copy of the website and try the migration process on the copy first to make sure the most important things still work fine.

The following user(s) said Thank You: simonlindsay

Please Log in or Create an account to join the conversation.

Time to create page: 0.061 seconds
Powered by Kunena Forum