Custom Item fields are not saved to the order

  • Posts: 25
  • Thank you received: 1
  • Hikashop Business
10 months 3 days ago #285719

-- HikaShop version -- : 3.2.2
-- Joomla version -- : 3.8.3
-- PHP version -- : 7.0

Hi, my customer is selling magazine subscriptions (among other things) and you can buy such a subscription as a present. For this, we added address fields for the address of the actual receiver in the product as custom fields of type item. They are displayed correctly, but when filling them out, adding the product to the cart and then ordering the subscription, these custom fields are not saved anywhere, are not send out via any of the mails that are sent and I have no idea what to do now. Right now it looks as if those fields are only displayed, but nothing is done with the data that is inserted there.

Any help? :-)

Regards,
Hannes

Please Log in or Create an account to join the conversation.

  • Posts: 63951
  • Thank you received: 9217
  • MODERATOR
10 months 3 days ago #285728

Hi,

This looks like the display settings of the custom fields are not configured properly. Could you check them, save them once, try again and if you still have the problem, provide a screenshot of the settings of one of the custom item fields ?

Please Log in or Create an account to join the conversation.

  • Posts: 14
  • Thank you received: 0
  • Hikashop Business
9 months 5 days ago #287649

nicolas wrote: Hi,

This looks like the display settings of the custom fields are not configured properly. Could you check them, save them once, try again and if you still have the problem, provide a screenshot of the settings of one of the custom item fields ?


Hi Nicolas
I'm having the same problem with the [entry] form where the client chooses an option and sets the date for it, but, the date is not included anywhere in any email or in the backend, I'm using the same hikashop version.
I will attach screen shoots in two posts.
many thanks in advanced

Please Log in or Create an account to join the conversation.

  • Posts: 14
  • Thank you received: 0
  • Hikashop Business
9 months 5 days ago #287652

other images

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 30
  • Thank you received: 0
9 months 5 days ago #287658

I have the same issue. Customers are entering their phone # on the order. But the phone # isn't be included in the email that's being sent out to us with the order in it.

Please Log in or Create an account to join the conversation.

  • Posts: 63951
  • Thank you received: 9217
  • MODERATOR
9 months 5 days ago #287653

Hi,

It's not the same issue.
Custom entry fields don't have display settings for emails, checkout, etc.
So it's normal that you don't see them there.

Please Log in or Create an account to join the conversation.

  • Posts: 14
  • Thank you received: 0
  • Hikashop Business
9 months 4 days ago #287688

nicolas wrote: Hi,

It's not the same issue.
Custom entry fields don't have display settings for emails, checkout, etc.
So it's normal that you don't see them there.


So basically the only thing that we can collect from the form are the actual products that we link to it if the customer select that option, true?

One more question please;; do I understand it correctly that the website can only have one entry form?

Please Log in or Create an account to join the conversation.

  • Posts: 63951
  • Thank you received: 9217
  • MODERATOR
9 months 2 days ago #287746

Hi,

You can see the custom entry fields in the menu Orders->Entries.

And yes, the website can only have one entry form.
It was designed to be used as a one time event registration for events like Joomladays.
If you need several forms, I would recommend looking instead at custom item fields, with several products, one for each form.

The following user(s) said Thank You: nadirdaoud

Please Log in or Create an account to join the conversation.

  • Posts: 30
  • Thank you received: 0
9 months 1 day ago #287911

Hey Nicolas... Okay, then how do I get the phone # into the email that is sent out to us with the order?

Please Log in or Create an account to join the conversation.

  • Posts: 11880
  • Thank you received: 1640
  • MODERATOR
9 months 7 hours ago #287916

Hello,

If it's not displaying, you'll probably have to edit the code of your email depending on how you collect these "phone #".
Also, note that the phone number used for the order is generally collected through the billing/shipping address using "Address custom fields", and it should already be displayed through your emails.

Please Log in or Create an account to join the conversation.

  • Posts: 30
  • Thank you received: 0
8 months 4 weeks ago #287985

That's the problem. It is showing in the "Address Custom Fields". But it's not showing up in any emails.

What email template file do i need to look at to check the code? And where exactly in that file do I need to check?

Please Log in or Create an account to join the conversation.

  • Posts: 63951
  • Thank you received: 9217
  • MODERATOR
8 months 4 weeks ago #287988

Hi,

If you've created a custom field of the table "address", you want to add its corresponding tag in the "address format" setting of the HikaShop configuration so that it will appear when the address is being displayed (in emails, in the invoice, in the order on the frontend, in the checkout).

Please Log in or Create an account to join the conversation.

Time to create page: 0.156 seconds
Powered by Kunena Forum