Ogone - Multilingual problem

  • Posts: 99
  • Thank you received: 3
  • Hikaserial Standard Hikashop Multisite
4 months 1 week ago #302576

-- HikaShop version -- : 4.0.1
-- Joomla version -- : 3.9.1
-- PHP version -- : 7.0.0

Hi,
we use a multilingual website, in ogone we have the accept url who let us put only one URL.
When we purchase a product, the email confirmation doesn't have any problem but the email of confirmation of payment has a problem and is always in english. In Ogone configuration we have the url :
xxxxx.com/index.php?option=com_hikashop&...pl=component&lang=en
If i visit the admin in english i have this url, if in FR so it shows fr, etc...
If i remove language parameter :
xxxxx.com/index.php?option=com_hikashop&...ogone&tmpl=component
Than the system use the default Joomla language website.
Any idea how to have the same language as the one used to book on email confirmation of payment?
Regards,
Olivier

Please Log in or Create an account to join the conversation.

  • Posts: 65706
  • Thank you received: 9590
  • MODERATOR
4 months 1 week ago #302579

Hi,

The payment notification email (that the merchant receives) is indeed in one language. But that's not a problem since it's for you.
The order status notification email (that the customer receives) is however sent based on the language stored in the order_lang parameter of the hikashop_order table, stored based on the current language of the customer when the order is created.
So it shouldn't be a problem that there is a lang parameter in the URL or not.
Can you please check your emails, know that you know all this ?

Please Log in or Create an account to join the conversation.

  • Posts: 99
  • Thank you received: 3
  • Hikaserial Standard Hikashop Multisite
4 months 1 week ago #302611

We have already check the order_lang parameter value in hikashop_order table. And it is storing correct value of language but still we are not getting correct language email on The order status notification email.

Please Log in or Create an account to join the conversation.

  • Posts: 65706
  • Thank you received: 9590
  • MODERATOR
4 months 1 week ago #302617

Hi,

Could you provide instructions to reproduce the problem on your website, a backend access, a FTP access and a link to this thread via our contact form so that we can have a look at the situation ? www.hikashop.com/support/contact-us.html

Please Log in or Create an account to join the conversation.

Time to create page: 0.057 seconds
Powered by Kunena Forum