Sagepay compliants for 14th September 2019

  • Posts: 250
  • Thank you received: 2
  • Hikashop Multisite
2 weeks 5 days ago #308167

-- url of the page with the problem -- : www.restorationuk.com
-- HikaShop version -- : 4.0.0
-- Joomla version -- : 3.9.8
-- PHP version -- : 7.1.30
-- Browser(s) name and version -- : Chrome

Hello my client as received a email from Sagepay about making sure the Sagepay integration is still compliant and to make any changes if necessary by 14th September 2019.

They shared a link of key elements which have been introduced to the authentication of online transactions: www.sagepay.co.uk/support/12/36/3d-secure-explained

Is this somethingI need to worry about or will the needed changes be made to the Sageypay plugin for Hikashop?

Thanks

Please Log in or Create an account to join the conversation.

  • Posts: 23549
  • Thank you received: 3654
  • MODERATOR
2 weeks 5 days ago #308178

Hello,

SagePay v2 plugin do not support 3DSecure so there is no change for that.
SagePay v3 plugin do not use the 3DSecure for the moment but the implement which is under development will directly use the latest API ; we want to release the new version of the plugin during the summer.

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

  • Posts: 250
  • Thank you received: 2
  • Hikashop Multisite
2 weeks 1 day ago #308272

Hello I believe we are on the Sagepay plugin version 3.2.0 is this the latest version and imagine we just need to wait for the new summer release which will support 3DSecure ready for September?

Thanks

Please Log in or Create an account to join the conversation.

  • Posts: 23549
  • Thank you received: 3654
  • MODERATOR
2 weeks 19 hours ago #308300

Hello,

After verification, the current version of the SagePay plugin is fully compatible with the 3D Secure authentication.
It uses the "Form Integration" which provides the necessary for the 3DSecure.

The "Direct Integration" is also compatible with the 3D Secure but it allows the customer to stay on the HikaShop website without the need of a redirection to the SagePay platform.

So, in any case, it's good !

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

Time to create page: 0.057 seconds
Powered by Kunena Forum