authoirize.net payment plugin isn't working

  • Posts: 105
  • Thank you received: 0
1 week 13 hours ago #332213

-- url of the page with the problem -- : skywayyachtworks.com/ships-store
-- HikaShop version -- : 4.4.2
-- Joomla version -- : 3.9.26
-- PHP version -- : 7.3
-- Error-message(debug-mod must be tuned on) -- : There was an error while processing your transaction:

We have activated and properly configured the authorize.net payment plugin and cannot get it to work in live or sandbox mode. We have confirmed that the correct keys etc have been entered.

Authorize.net confirms that transactions are not arriving in their system but Hikashop shows them as 'completed.'

After the customer enters cc info etc and submits, they get the error message and are brought back to the checkout page.

Hikashop was working properly with the previous payment processor and plugin we were using.

Last edit: 1 week 13 hours ago by dagroupinc. Reason: corrected info and typo

Please Log in or Create an account to join the conversation.

  • Posts: 24855
  • Thank you received: 3828
  • MODERATOR
4 days 19 hours ago #332224

Hello,

Your sent a message via the "contact us" form and Nicolas answered you.
It looks like you did not see his reply ; please check your spam folder, etc.

Hi,

That error message indicates that you're using the AIM mode of the Authorize.net payment method.
Normally, after the ":" of that message, you're supposed to get the error message from Authorize.net.
Since you don't, and they tell you that they don't see the transactions attempts, I would suppose that the issue is coming from the URL you've configured in the settings of the payment method which is not correct and thus it's sending the transaction request to somewhere else which doesn't return anything valid.
Please check that the URL setting has the value secure.authorize.net/gateway/transact.dll
which is the URL of the Authorize.net AIM payment gateway.

If that doesn't help, please provide a screenshot of the settings of your payment method.
Also, I would recommend doing a test with the "SIM". In that case, you'll be redirected to Authorize.net's payment page at the end of the checkout and you'll directly see the message from Authorize.net about what is wrong.

Best regards,
Nicolas


Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

  • Posts: 105
  • Thank you received: 0
4 days 10 hours ago #332248

1) Correct, your email didn't come through to me
2) We entered the URL that Authorize.net provided to us: api.authorize.net/xml/v1/request.api
3) plugin is configured to use SIM.

Next
4) We configured with the URL you provided and now the error message is:

The referrer, relay response or receipt link URL is invalid.

Neither the hosting provider or authorize.net seem to have a solution and I don't ever remember having to configure a relay response URL for Hikashop or Authorize.Net before

Please Log in or Create an account to join the conversation.

  • Posts: 72729
  • Thank you received: 11084
  • MODERATOR
3 days 23 hours ago #332251

Hi,

The URL api.authorize.net/xml/v1/request.api is for another API of Authorize.net, not SIM or AIM.

Looking online for that error message, the first page I found is this one:
www.123formbuilder.com/docs/authorize-ne...e%20error%20persists .
This says that the most likely cause for that error message is that the URLs configured in your Authorize.net merchant are wrong and that they should be removed (HikaShop's authorize.net plugin generates and sends them automatically to Authorize.net for each transaction).
The second link I found, from Authorize.net's own documentation indicates that the issue usually happens when one of the URL sent by the website is different from the one configured in the merchant account:
support.authorize.net/s/article/Error-14...ponse-URL-is-invalid
So please check the URL settings of your Authorize.net merchant account as described on that page.

Please Log in or Create an account to join the conversation.

  • Posts: 105
  • Thank you received: 0
3 days 14 hours ago #332283

The documentation also says that AIM, SIM, and DPM are obsolete and in the process of being phased out. However, those appear to be the only options available in the plugin. Does that mean the plugin needs to be updated—a new version created?

Not sure I understand what URL needs to be entered in the 'Response URL'

Seems that authorize.net tech support doesn't have a clue either.

Please Log in or Create an account to join the conversation.

  • Posts: 105
  • Thank you received: 0
3 days 14 hours ago #332285

I was finally able to speak with a helpful person and HikaShop now connects to authorize.net — apparently, the return URL needs to be the URL of our own website (whitelist security layer).

However, the CC form and transactions take place on the authorize,net site and not on our own in HikaShop — how do I configure that? They told me that we need to use accept.js?

Last, is the 'return URL field in the plugin where customers are taken to after completing a transaction—such as a thank you page?

Please Log in or Create an account to join the conversation.

  • Posts: 72729
  • Thank you received: 11084
  • MODERATOR
3 days 6 hours ago #332284

Hi,

While the AIM and SIM APIs are obsolete, they are still working.
The response URL should be empty in your merchant account. It's because it is filled that you get that error message.
Regarding a new version of the plugin for authorize.net, our partner Obsidev actually developed it a while back. It's available on our marketplace here:
www.hikashop.com/marketplace/product/150...e-js-by-obsidev.html

Please Log in or Create an account to join the conversation.

Time to create page: 0.074 seconds
Powered by Kunena Forum