[Solved} 25% padding in main position when not using Hika filter

  • Posts: 69
  • Thank you received: 1
  • Hikashop Multisite
1 week 3 days ago #312764

-- url of the page with the problem -- : formidogrijswijk.nl/vers
-- HikaShop version -- : 4.2.2
-- Joomla version -- : 3.9.12
-- PHP version -- : 7.2

Good afternoon

Hikashop has a default (left) position for the filters when they are added by the component.

I use a JoomDev template: JD_Shop

When I opt to use the hikashop filter module (to place the filters in another position) there is still a 25% margin on the right side of the main (component) area.

I have been puzzling where to "fix" this.
I feel it has to do with hikashop... as other components don't produce this padding.
Does anyone have a clue where the setting is?

Thankful for help

Dick

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 67389
  • Thank you received: 9992
  • MODERATOR
1 week 2 days ago #312768

Hi,

No, that's not a problem in HikaShop.
In the module, there are display options for the different areas. If the module is configured to not be displayed on a page, then it won't output any HTML.
Then, in the code of the template, there is some code to say whether the area should be displayed or not. There are two methods for that:
- get the HTML of each module and if there is something to display, display the area (position).
- ask Joomla if the module is to be displayed in that area.
Your template went with the second solution, which means that even if the module doesn't output any HTML, it still displays the area.
stackoverflow.com/questions/38928629/how...module-has-an-output
If you disable the HikaShop filter module, and instead activate the "filter" display of the menu item, then the filters will display at the top of the listing and you won't get the filter module on the left area. You'll see that you won't have the problem with the empty area.

Please Log in or Create an account to join the conversation.

  • Posts: 69
  • Thank you received: 1
  • Hikashop Multisite
1 week 2 days ago #312772

Thank you for your answer Nicolas

I feel I don't totally "grasp" your answer.

I have tried your option... without the desired effect
Please look at my settings in the attached image.

The result is that the filters show on the LEFT, not ABOVE
You can see it here

Another way
If I publish the Hikashop filter module, but assign it to none of the pages and enable the filter option in the menu... the effect is the same: the filters show in the left poition.

What I desire is: to display the filters in the LEFT position, but by use of the module option so that I can show other modules in the left position as well.

I hope there is apossibillity for this

Dick

Attachments:
Last edit: 1 week 2 days ago by Formidog.

Please Log in or Create an account to join the conversation.

  • Posts: 2287
  • Thank you received: 298
  • MODERATOR
1 week 2 days ago #312777

Hello,

I think that there is a misunderstood, follow me step by step to better understand the situation :
=> Use a default template like ProtoStar

You will see that the fact that your filter isn't above is only coming from your template, as with the ProtoStar your filter may be above your listing.
In order to have what you requested, we invite you to contact the template creator.

Regards

Please Log in or Create an account to join the conversation.

  • Posts: 69
  • Thank you received: 1
  • Hikashop Multisite
1 week 1 day ago #312800

Good morning

Thanks for the added info
I fully understand now

The issue is reported in two threads on the JoomDev forum:
www.joomdev.com/forum/jd-shop/3651-solve...hop-filters-position
and
www.joomdev.com/forum/jd-shop/4012-25-pa...ot-using-hika-filter

There is no desired action until this morning

Is there any PHP wizzard who feels to lend a helping hand with a fix???
Please?


Greetz,
Dick

Please Log in or Create an account to join the conversation.

  • Posts: 67389
  • Thank you received: 9992
  • MODERATOR
1 week 1 day ago #312804

Hi,

Note that if you see the filter module area empty, while you see the filters at the top of the listing (or on the left side with your template), this indicates that you didn't select the filters to be displayed in the settings of the filter module.
So check this out via the Joomla modules manager.

Please Log in or Create an account to join the conversation.

  • Posts: 69
  • Thank you received: 1
  • Hikashop Multisite
1 day 15 hours ago #313009

The issue was caused by some hard code in the template
they removed the line and the issue is solved by JoomDev templaters.

The template works now in the Joomla/Hikashop way

Thanks all
Dick

Please Log in or Create an account to join the conversation.

Time to create page: 0.073 seconds
Powered by Kunena Forum