Product variant will not display custom field

  • Posts: 18
  • Thank you received: 1
3 weeks 3 days ago #321052

-- url of the page with the problem -- : www.macnaughton-macmillan.org/site/index...product/11571-donate
-- HikaShop version -- : 3.5.1
-- Joomla version -- : 3.9.19
-- PHP version -- : 7.2
-- Browser(s) name and version -- : MS Edge 83.0.478.50 (Official build) (64-bit)
-- Error-message(debug-mod must be tuned on) -- : N/A

Greeting,
I am setting up donations on our Shopping Cart.
I realize that the software is not updated but we just recently decided to start using it again so I am trying to get it running while waiting for the funds to update the subscription.

I need to set up a Donations "product" but I am having problems w/ a couple of things.
1) I need 2 types of donations;
a) Operation Costs
b) In Memoriam
2) W/ the Memoriam donation I need a text box where the user can type their memorial.

I have already done several of the preliminary steps:
1) Set up the product w/ 2 variants
2) Created a custom field (text field) for the amount.
3) Created a 2nd custom field (text box) for the memorial statement.

The Donation Amount displays fine but I just can't seem to get the "Memoriam" Variant to display the text box.


====================================
Michael S. "Mac" Miller
Webmaster
Bengalhome Enterprises
This email address is being protected from spambots. You need JavaScript enabled to view it.

Please Log in or Create an account to join the conversation.

  • Posts: 70022
  • Thank you received: 10487
  • MODERATOR
3 weeks 2 days ago #321086

Hi,

There is no mechanism to hide / display custom item fields based on the selected variant.
So when you create custom item fields, they will always display on the product regardless of the variant selected.
If you don't see a custom field, it means that either you turned off its display option for the area where you're trying to display it or you've restricted it to another product / category / user group and that's why you don't see it.
So if you don't see it while you want, it's probably an issue with the settings of the custom field itself.
Could you provide a screenshot of its settings please ?

Please Log in or Create an account to join the conversation.

  • Posts: 18
  • Thank you received: 1
3 weeks 1 day ago #321124

Nicolas,
Here are the 4 screenshots.






Mac


====================================
Michael S. "Mac" Miller
Webmaster
Bengalhome Enterprises
This email address is being protected from spambots. You need JavaScript enabled to view it.
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 18
  • Thank you received: 1
3 weeks 1 day ago #321130

I figured out what I was doing wrong.
Thanks Much Nicolas.

Mac


====================================
Michael S. "Mac" Miller
Webmaster
Bengalhome Enterprises
This email address is being protected from spambots. You need JavaScript enabled to view it.

Please Log in or Create an account to join the conversation.

Time to create page: 0.078 seconds
Powered by Kunena Forum