Google Analytics Products Plug-in Not Working

  • Posts: 248
  • Thank you received: 2
  • Hikashop Multisite
2 years 8 months ago #249746

-- HikaShop version -- : 2.6.4
-- Joomla version -- : 3.6.2

We've set up the Hikashop Google Analytics Plugin (settings attached). Since we set it up we've had over 20 orders confirmed on the website, but only 3 have actually transferred to our Google Analytics account (In the Ecommerce conversions area).

Do you have any idea why it's not reporting everything?

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 23419
  • Thank you received: 3638
  • MODERATOR
2 years 8 months ago #249750

Hi,

Please use the "universal analytics" mode with "Direct Call" setting (also called Measured Protocol).

The "direct call" is useful because when the order is confirmed thanks to the IPN system (server to server) ; there is no javascript processed.
And there is no page displayed by the customer.
Because we can't be sure that the customer will ever return to the website (a huge number of customer had that problem) ; we use that "direct" call to keep a track of the order and his confirmation.

Now the "direct call" is not perfect because it won't provide the same "client ID" than the customer who made the order.
We have some patchs/improvements in progress for the plugin but we need to do more tests before being able to release them.

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.
The following user(s) said Thank You: dancingkazzaf

Please Log in or Create an account to join the conversation.

  • Posts: 248
  • Thank you received: 2
  • Hikashop Multisite
2 years 8 months ago #249779

Hi Jerome,

Thanks for your help, i'll make these changes and see how it goes. :)

Please Log in or Create an account to join the conversation.

Time to create page: 0.058 seconds
Powered by Kunena Forum