order email notifications after purchase

  • Posts: 4
  • Thank you received: 0
6 years 8 months ago #281104

-- url of the page with the problem -- : peak-performance.org.uk/index.php/en/store/public
-- HikaShop version -- : 3.2.0
-- Joomla version -- : 3.7.4
-- PHP version -- : 7
-- Browser(s) name and version -- : chorme, firefox

Hi guys, ive spent the last 6 hours going through your forums and trying different options, but have had now joy. when a customer buys a product we receive a paypal email but no hikashop email, neither does the customer.

the joomla settings are right as im using breezing forms and we are receiving email through the website. i have filled in the email section in hikashop config and gone into email and checked everything is enabled.

we are using office 356 to host our emails, have you come across any issues before with office 365.

hope you can help

david

Please Log in or Create an account to join the conversation.

  • Posts: 82095
  • Thank you received: 13195
  • MODERATOR
6 years 8 months ago #281106

Hi,

Is the status of the order changed to "confirmed" automatically ?
If no, then it's a payment notification issue:
www.hikashop.com/support/documentation/i...l-error.html#already
If yes, then the problem is an email sending issue and you should check the menu Customers>Email history.
If you see the emails there, then it's indeed the office 365 email sending which doesn't like the emails, or that they end up in the spam.
If you don't, it's probably that the emails are disabled in the menu System>Emails or something like that.

Please Log in or Create an account to join the conversation.

  • Posts: 4
  • Thank you received: 0
6 years 8 months ago #281281

hi there,

is email history a menu item under customers, as i cant seen to find it. i change the joomla email settings and hikashop emails settings to gmail, but it still didnt send notification emails.

can i send someone so logins to see if they can fix this issue, i really dont want to use virtuemart i hate it.

Please Log in or Create an account to join the conversation.

  • Posts: 26072
  • Thank you received: 4015
  • MODERATOR
6 years 8 months ago #281305

Hello,

If you cannot see any entry for that email in the history log it means that the email is not sent.
So, as Nicolas wrote:

If you don't, it's probably that the emails are disabled in the menu System>Emails or something like that.

Would it be possible to have some details about your emails in "System > Emails" ?

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

  • Posts: 26
  • Thank you received: 1
3 years 8 months ago #325827

Hi there,

I am having the same problem. If I check under the email history in hikashop, it says the emails have been sent. So, it appears office 365 doesn’t like this email thing. Any further information on how to get it working?

Please Log in or Create an account to join the conversation.

  • Posts: 82095
  • Thank you received: 13195
  • MODERATOR
3 years 8 months ago #325836

Hi,

If the email is in the email history, then HikaShop sent the email to your email server so that your email server could send it to the recipient email server.
So first, check that you can send a test email via the Joomla configuration page's email test button.
If that works, then the email settings of the joomla configuration are correct.
So you're left with two possibilities:
- the email settings of the HikaShop configuration are not correct for your email server
- your email was actually sent by your email server to the recipient email server but the recipient email server rejected it because it flagged it as a spam.
There are two things you can do to move forward:
- check the email with mail-tester.com It will tell you if the recipient server is likely to flag the email as a spam or not and what you can improve.
- contact the support of your email server provider (probably your hosting company ?) with a copy of the email information from the history so that they can check the log of the email server for that email. Their should be logged the reason why the email was not received by the recipient.

Please Log in or Create an account to join the conversation.

  • Posts: 1
  • Thank you received: 0
3 years 8 months ago #325892

I`am Having same issue, but little client receive email when checkout are done and I don`t receive any notification by email:blush: :blush: :blush: :blush: :blush: :blush:
Spam Box are clear, Email Server are checked, just me seller side no any notification.

Please Log in or Create an account to join the conversation.

  • Posts: 26
  • Thank you received: 1
3 years 8 months ago #325894

Hi Nicolas,

thanks for the response.

So, as far is I can see, the mail is sent via the joomla configuration page's email test button. I receive the testmail.

The strange thing is, the the emails for emailadress that should receive the notifications from Hikashop, are also imported into my gmailaccount. And there I do receive the emails, just not in Outlook 365.

Please Log in or Create an account to join the conversation.

  • Posts: 82095
  • Thank you received: 13195
  • MODERATOR
3 years 8 months ago #325924

Hi,

@andretsc :
Did you check the menu Customers>Emails history ? Do you see the emails there ? If no, then the emails might be disable in the menu System>Emails or your website might not receive the payment notifications from your payment gateway ? Is the status of your orders changed to "confirmed" automatically after the payment ? If no, then you likely have an issue with the payment notifications:
www.hikashop.com/support/documentation/i...or.html#notification

@OtenKing1 :
So if I understand correctly, you mean that the emails do arrive in the mailbox (on gmail) but then your email client is not receiving them from the mailbox. Then, it must be either a filter issue on your gmail account, or a filter issue in your outlook client. I'm not familiar with how outlook works so I wouldn't be able to help on that end.

Please Log in or Create an account to join the conversation.

  • Posts: 26
  • Thank you received: 1
3 years 8 months ago #325929

You have Office 365 as well?

Please Log in or Create an account to join the conversation.

  • Posts: 26
  • Thank you received: 1
3 years 8 months ago #325946

Thanks for your response! I think the next thing to look at, might be the filtering you mentioned in the mail client.

Before I switched to Office 365, I used Office 2010. In that situation, I did receive the emails in Outlook 2010 and in Gmail.
With Office 365, I switched to Microsoft Exchange and had to change DNS etc. I have been on the phone with Microsoft helpdesk for 3 hours already and they have no clue either. Very frustrating.

Please Log in or Create an account to join the conversation.

Time to create page: 0.103 seconds
Powered by Kunena Forum