hikashop dashboard statistic graph not working correctly

  • Posts: 202
  • Thank you received: 7
  • Hikaserial Subscription Hikashop Business
5 months 2 weeks ago #303381

Hello,
since updating to 4.0.1 the dashboard graph does not show values correctly

see: www.screencast.com/t/k41DZMypJTj
see also: www.screencast.com/t/mHH5WsW6

I checked the order statuses configurations and everything seems fine there, see: www.screencast.com/t/Tendm9AF

the order listing works fine and I can correctly generate reports, it's just the dashboard graph that is not working, so it's not a big issue, but it was handy to be able to check the months orders quickly form there

Thanks

Please Log in or Create an account to join the conversation.

  • Posts: 2188
  • Thank you received: 292
  • MODERATOR
5 months 2 weeks ago #303417

Hello,

We don't see how the update can leads to modify order report.
I suggest you to check all your relative settings, I think about your order status, and especially the ones you have created, there must be something that have been changed or leads to this kind of results.

If you can't find what's wrong, can you use our Contact us form to provide backend access, don't forget to add an Url link to this topic to keep the link.
Awaiting news from you.

Regards

Last edit: 5 months 2 weeks ago by Philip.

Please Log in or Create an account to join the conversation.

  • Posts: 202
  • Thank you received: 7
  • Hikaserial Subscription Hikashop Business
5 months 2 weeks ago #303450

Hello,
I am sending you the access details to my test site now.
Feel free to mess around there (as soon as you keep it offline).

I cannot find anything wrong in my order statuses configs.

see: www.screencast.com/t/GtqL2whxP

I noticed tat if I enabled in statistics also the "created" orders, than all the order are registered correctly in the dashboard graph,
but is still an issue because also the "created" orders are being registered and so the statistics are off

If i disable the "created" orders, then the orders are not being registered correctly in the dashboard graph, some are, some aren't, I don't exactly understand which one are being showed.

I have created a "sales TOTAL" report in the Reports section which shows the correct money amount for december and january, so you can more easily check if the dashboard statistics are off.

Thank you

Please Log in or Create an account to join the conversation.

  • Posts: 66308
  • Thank you received: 9733
  • MODERATOR
5 months 2 weeks ago #303457

Hi,

The issue is that since the "created" status is not set for the statistics column, the statistics are based on the date of creation of the invoice number. However, in the System>Order statuses menu, you didn't activate other statuses than "confirmed" under the "invoice" column and thus most of the orders with a status enabled in the statistics column don't have a invoice creation date and thus are not taken into account.
Now if you enable these statuses in the invoice column, that won't directly solve the problem since the previous orders still won't have an invoice number.
What you should do then is to run a mass action to set the order_invoice_created with the value of order_modified and the order_invoice_id with the value of order_id.

Please Log in or Create an account to join the conversation.

  • Posts: 202
  • Thank you received: 7
  • Hikaserial Subscription Hikashop Business
5 months 2 weeks ago #303483

Thank you for looking into this.
I think I understand, but is still strange because I never generated invoices before 1 month ago (in the order statuses > invoice column all the orders were UNselected).
Infact I think the issue began when I selected an order status to generate invoices the first time, maybe it's the same thing that you are saying.

What you should do then is to run a mass action to set the order_invoice_created with the value of order_modified and the order_invoice_id with the value of order_id.

mmmh... not sure how to do this. I do see the action option "update values" in mass action, but it seems it requires some coder expertise to run that correctly.

see: www.screencast.com/t/1Ohe12SvXxw

Please Log in or Create an account to join the conversation.

  • Posts: 202
  • Thank you received: 7
  • Hikaserial Subscription Hikashop Business
5 months 2 weeks ago #303484

Anyway, look... it's not a big issue, I'll just create a mass action to change all created orders to pending after 3 days and will set created orders to show in the statistics too, I just tried and now the statistics are pretty accurate.

Thanks again

Please Log in or Create an account to join the conversation.

Time to create page: 0.053 seconds
Powered by Kunena Forum