Question about product creation page "Shipping Prices"

  • Posts: 200
  • Thank you received: 12
  • Hikamarket Multivendor Hikashop Business
1 year 2 weeks ago #319988

-- HikaShop version -- : 4.3.0
-- HikaMarket version -- : 3.1.0
-- Joomla version -- : 3.9.18
-- PHP version -- : 7.2.30

Hello

We are facing the following problem when Vendor creates new product.
All fields show when creating a new product except from the "Shipping Prices" that show after you click on Apply or Save.
Our setting for "Checkout addresses and Shipping" / Force shipping regardless of weight is set to YES so there is no reason for the product first.

How to show "Shipping Prices" directly when product creation page loads instead of having to save the product first?

Please Log in or Create an account to join the conversation.

  • Posts: 24913
  • Thank you received: 3846
  • MODERATOR
1 year 2 weeks ago #319991

Hello,

I'm not able to reproduce your issue in my local website.
Can you check your HikaMarket ACL and see if you don't have specific rights for "product / new" ?

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

  • Posts: 200
  • Thank you received: 12
  • Hikamarket Multivendor Hikashop Business
1 year 2 weeks ago #320021

Thank you for your reply Jerome but there is nothing you need to reproduce. This is how your DEMO site works.

I am giving screenshots to make our question more clear...



Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 24913
  • Thank you received: 3846
  • MODERATOR
1 year 2 weeks ago #320036

Hello,

Our demo website do not have the "shipping price" plugin enabled.
So I don't know from where your screenshots are coming from but it's not the official HikaShop demo website.

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

  • Posts: 200
  • Thank you received: 12
  • Hikamarket Multivendor Hikashop Business
1 year 2 weeks ago #320053

Jerome thank you for your answer...

The above screenshots are from our website.

Now take a look at the screenshots from your DEMO website:

1. Logged in to your demo website went to the Vendor Control Panel and created a shipping method



2. After we have created a shipping method, we move to the products page to create a new product.


3. In the same page if we click on "Apply" the Shipping appears!


Now that we have screenshots of your DEMO site too, please tell us how we can set your component to show "Shipping Prices" without having to click on "Apply" first.

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 73081
  • Thank you received: 11164
  • MODERATOR
1 year 2 weeks ago #320081

Hi,

Thank you for the details. We were able to reproduce the issue thanks to that and added a patch.
Please install this new version of the "shipping prices" plugin via the Joomla installer and it will then work properly. We'll include the patch on our end too for the next version of HikaShop.

File Attachment:

File Name: shippingma...ices.zip
File Size:11 KB

Attachments:
Last edit: 1 year 2 weeks ago by nicolas.
The following user(s) said Thank You: liaskas

Please Log in or Create an account to join the conversation.

  • Posts: 200
  • Thank you received: 12
  • Hikamarket Multivendor Hikashop Business
1 year 2 weeks ago #320113

Thank you for your kind help Nicolas!

Please Log in or Create an account to join the conversation.

  • Posts: 200
  • Thank you received: 12
  • Hikamarket Multivendor Hikashop Business
11 months 2 weeks ago #321595

Hello again Nicolas

After some time we updated the plugin with the one you gave us here, but it does not seem to have any effect on our end. Still shipping prices are not visible in product creation page, till you click on Apply.

Please Log in or Create an account to join the conversation.

  • Posts: 73081
  • Thank you received: 11164
  • MODERATOR
11 months 2 weeks ago #321659

Hi,

The shipping prices area will not appear for a new product. You need to save the product once and then you'll have it when you edit the product.
So what you're describing is normal.

Please Log in or Create an account to join the conversation.

  • Posts: 200
  • Thank you received: 12
  • Hikamarket Multivendor Hikashop Business
11 months 2 weeks ago #321661

Nicolas thank you but what you tell us now is completely different than what you have told us so far in this thread. You have sent us a plugin update that fixes this issue.

Also...
on your demo site, the shipping prices appears on product creation page without saving the product.

Waiting for your reply...

thank you.

Please Log in or Create an account to join the conversation.

  • Posts: 200
  • Thank you received: 12
  • Hikamarket Multivendor Hikashop Business
11 months 1 week ago #321739

Hello again...

Almost 4 days have passed till our last reply on this thread but still no sign of a solution proposal.

Our Marketplace is almost completed but there are a few spots that do not allow us to set it online in public and this issue here is one of these spots.

The problem is described in details, confirmed by the HikaShop support team, fixed on your demo site and a plugin update was proposed to us as a solution.

Well the plugin update does not have any effect on the issue, and we are expecting for an answer.

Maybe our last post was not seen, so we post again to bring it back as an issue that requires your attention.

Thank you!

Please Log in or Create an account to join the conversation.

  • Posts: 3208
  • Thank you received: 425
  • MODERATOR
11 months 1 week ago #321855

Hello,

Just a try, but I think that in order to "fix" product data you have to "Save" your product again to see the correction ?
Can't be sure of it, but did you process this test, it's quick can do a lot in your issue, because theorically your product data in your Sql have to be reset.

Hope this will help.
Regards

Please Log in or Create an account to join the conversation.

  • Posts: 200
  • Thank you received: 12
  • Hikamarket Multivendor Hikashop Business
11 months 1 week ago #321879

Thank you for your reply Philip.

The issue is this...

Vendor goes to add a new product on our site and he sees the following form. As you can see there is no "Shipping Prices" anywhere!



Same procedure on HikaShop demo site:

Vendor goes to add a new product on your demo site and he sees the following form. As you can see "Shipping Prices" show without saving when the page loads!


What we need is our site to be as your demo site.

Attachments:
Last edit: 11 months 1 week ago by liaskas.

Please Log in or Create an account to join the conversation.

  • Posts: 3208
  • Thank you received: 425
  • MODERATOR
11 months 1 week ago #321887

Hello,

I'm afraid I wasn't clear enough, I mean you have to save your product in the backend in order to reformat the data relating to shipping prices and thanks to the fix.
Can you try that please just to be sure ?

Regards

Last edit: 11 months 1 week ago by Philip.

Please Log in or Create an account to join the conversation.

  • Posts: 200
  • Thank you received: 12
  • Hikamarket Multivendor Hikashop Business
11 months 6 days ago #321922

Thank you again for your reply Philip.

What we did step by step...

Logged in as a Vendor in our marketplace

Created a new product and saved.

Then from the backend as admin we edited the product and resaved.

Then again from the frontend as a vendor go to create another new product. Still no "Shipping prices" on product creation page before saving the new product.

Do not know if this is what you wanted us to try.

We can provide login credentials to check if possible.

Thank you

Please Log in or Create an account to join the conversation.

  • Posts: 3208
  • Thank you received: 425
  • MODERATOR
11 months 5 days ago #321941

Hello,

So far, we didn't see any solutions, unfortunatelly we aren't able to reproduce your issue...
we will have to go more far so can you provide via our Contact us form :
- Ftp access
- Backend/frontend access as well
- Url link to product where you have your issue.
- A detailed step by step process to precisely reproduce your issue

Awaiting news from you.
Regards

Last edit: 11 months 5 days ago by Philip.

Please Log in or Create an account to join the conversation.

  • Posts: 200
  • Thank you received: 12
  • Hikamarket Multivendor Hikashop Business
11 months 5 days ago #321950

Thank you Philip

Details were sent through "Contact us"

Please Log in or Create an account to join the conversation.

  • Posts: 3208
  • Thank you received: 425
  • MODERATOR
11 months 5 days ago #321965

Hello,

thanks for you return and your concrete case, we were able to create a fix on your case, the point is that on our Demo Website our shipping method wasn't restricted by a vendor.
Apparently on your side you need to restrict shipping method per vendor and so we provide a fix to manage this configuration.
We had it to our version (for our future release) and directly on your website.

Thank you for your trust and patience.
Regards

Last edit: 11 months 5 days ago by Philip.

Please Log in or Create an account to join the conversation.

  • Posts: 200
  • Thank you received: 12
  • Hikamarket Multivendor Hikashop Business
11 months 4 days ago #321979

Thank you for your reply Philip and for your willing to understand the problem.
It is working fine now!

Unfortunately we discovered another problem that is related to "Shipping prices"

Step by step explanation so that you can understand where the new problem is:

Our setting is so that the new products need to be approved.

Vendor creates new product and he provides all info related to this product including "shipping prices" and the blocking of unwanted shipping methods.
Vendor now saves his new product and the admins have to approve the new product.

After the new product is approved by admins, all "Shipping prices" settings are lost like they have never been created!

Can you please advise?

Please Log in or Create an account to join the conversation.

  • Posts: 3208
  • Thank you received: 425
  • MODERATOR
11 months 1 day ago #322098

Hello,

Sorry for the delay, will have to take more time to get the root issue, but we had progressed on the subject, it seems that are a compatibility issue with HikaMarket.
We hope have a solution quite soon, to solve this issue.
Regards

Please Log in or Create an account to join the conversation.

Time to create page: 0.135 seconds
Powered by Kunena Forum