No shipping method found

  • Posts: 13
  • Thank you received: 0
  • Hikashop Business
1 year 4 months ago #332466

-- url of the page with the problem -- : www.apalachee-minerals.com
-- HikaShop version -- : 4.4.2
-- Joomla version -- : 3.9.25
-- PHP version -- : 7.3.28
-- Error-message(debug-mod must be tuned on) -- : No Shipping Method Found

When customers check out, they now get the message "No shipping method found". We are using the USPS shipping plugin, and it had been working fine until a week ago. I'm not sure what has changed to create the error.

Please Log in or Create an account to join the conversation.

  • Posts: 12953
  • Thank you received: 1777
1 year 4 months ago #332477

Hello,

Firstly, can you follow each step of the "Shipping methods" section of our FAQ and test it again ?
If you're still having that issue, can you show us screenshots of how you configured :
- your shipping method ("Hikashop->System->Shipping methods")
- your product dimensions / weight
- your checkout workflow via "Hikashop->System->Configuration->Checkout workflow"

Kind regards,
Mohamed.

Please Log in or Create an account to join the conversation.

  • Posts: 13
  • Thank you received: 0
  • Hikashop Business
1 year 4 months ago #332975

Sorry for the delayed response. This isn't the only site we manage.

As per your response, here is additional information. I'm attaching screen shots for each.

First image: our only published shipping method uses the USPS plugin.


Second Image: product dimensions are in millimeters(mm), the weight is in grams (g). Screen shot of a product is attached.
Third image: this is our checkout flow, showing the shipping selection.

Once again, I apologize for the delay, but I hope this gives you the right information.

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 12953
  • Thank you received: 1777
1 year 4 months ago #332989

Hello,

Once again, I apologize for the delay, but I hope this gives you the right information.

No problem, we're always here to help !

Can you also show us how you configured your USPS shipping method options ? From what I can see, it can be a problem is the currency used during the checkout workflow is different than USD.

Kind regards,
Mohamed.

Please Log in or Create an account to join the conversation.

  • Posts: 13
  • Thank you received: 0
  • Hikashop Business
1 year 3 months ago #333094

Here is a screenshot of our settings in the USPS shipping plugin. We use USD exclusively for products and for shipping.

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 12953
  • Thank you received: 1777
1 year 3 months ago #333116

Hello,

In that case, can you send us a temporary back-end access through our contact form and add a link to that thread in your message so that we can directly test and debug ? Thank you.
www.hikashop.com/support/contact-us.html

Kind regards,
Mohamed.

Last edit: 1 year 3 months ago by Mohamed Thelji.

Please Log in or Create an account to join the conversation.

  • Posts: 13
  • Thank you received: 0
  • Hikashop Business
1 year 3 months ago #333181

Info sent.

Please Log in or Create an account to join the conversation.

  • Posts: 76554
  • Thank you received: 12020
  • MODERATOR
1 year 3 months ago #333276

Hi,

We got the access and were able to check your situation.
It's working fine as far as I can see:
i.imgur.com/KdUNxFA.png
Can you please double check ?
I only see the error message "no shipping method found" before I enter my shipping address, and that's normal since the USPS plugin needs the shipping address to calculate the shipping fee and you don't have any other shipping methods enabled.

Until last week, I would have recommended you to configure your checkout workflow in the HikaShop configuration as a two step checkout so that the shipping view is only visible after the address has been entered.
However, with the current version of HikaShop (you can update to the 4.4.3 by manually downloading it on our website and installing it on yours), you have an extra setting in the "shipping" view of the checkout workflow allowing you to turn off the display of error messages from that view so that it won't display that error message before the address is entered.

Please Log in or Create an account to join the conversation.

  • Posts: 13
  • Thank you received: 0
  • Hikashop Business
1 year 3 months ago #333321

This fixed it! I also took an extra step of separating the shipping to another view. I genuinely appreciate all of the assistance you have given.

Please Log in or Create an account to join the conversation.

Time to create page: 0.109 seconds
Powered by Kunena Forum