Gray transparent overlay on browsers window

  • Posts: 27
  • Thank you received: 1
2 weeks 5 days ago #322224

-- HikaShop version -- : 4.3.0 Business
-- Joomla version -- : 3.9.20
-- PHP version -- : 7.3.18
-- Browser(s) name and version -- : Firefox and Chrome
-- Error-message(debug-mod must be tuned on) -- : None

Hi,
I made my Terms & Conditions article and in my checkout settings I assigned it to this article.
When ik place an order on the site, the article will not show but instead of this, there will be a gray transparent overlay on my screen.
(see screenshot)


Could anyone tell me what is going wrong?

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 2647
  • Thank you received: 348
  • MODERATOR
2 weeks 4 days ago #322226

Hello,

I process some tests directly on your website, and we were able to see your issue but not to get clues on your current issue.
Can you process some tests with a default template like ProtoStar to see if that change something to your issue.

If it happen with a default template like Protostar then provide these relatives elements :
- Your terms and condition article setting screenshot
- Your checkout Workflow screenshot

Hope this will help us to progress on your subject.
Regards

Last edit: 2 weeks 5 days ago by Philip.

Please Log in or Create an account to join the conversation.

  • Posts: 27
  • Thank you received: 1
2 weeks 4 days ago #322252

Hi Philip,

Thanks for this suggestion, everything works fine with prostar so there must be a problem with my bootstrap template.
Don't know how to solve it.

Regards, Theo

Please Log in or Create an account to join the conversation.

  • Posts: 27
  • Thank you received: 1
2 weeks 4 days ago #322253

Maybe I have to make a custom made link in the layout.
Can you give me a hint on how to do that?

Or maybe I can change the file in a way that the Terms & Conditions will open in a new window and not in modal window?

Last edit: 2 weeks 4 days ago by sitemoves.

Please Log in or Create an account to join the conversation.

  • Posts: 70194
  • Thank you received: 10508
  • MODERATOR
2 weeks 4 days ago #322255

Hi,

That's your template which has a conflict with the popup mode you're using. Go in the HikaShop configuration, and under the "Display" tab, change the "popup mode" setting to "vex" and it should then work fine.

Please Log in or Create an account to join the conversation.

  • Posts: 27
  • Thank you received: 1
2 weeks 4 days ago #322261

Hi Nicolas,

That works fine indeed except for the link to my Terms & Conditons.
The link opens a non excisting page, while I realy set the right page in the checkout workflow

Please Log in or Create an account to join the conversation.

  • Posts: 2647
  • Thank you received: 348
  • MODERATOR
2 weeks 3 days ago #322291

Hello,

Then you have to contact your template creator because after a quick analyze it seems that something is that leads to this new issue.
There are an Jquery error that come from Joopstrapbase that leads to a 500 error, means that your terms & conditions isn't find.

Can you activate the error reporting et set the debug mode to developement error, then have a look of information displayed.
Awaiting a screenhot of this information to be able to progress on your subject.

Regards

Last edit: 2 weeks 3 days ago by Philip.

Please Log in or Create an account to join the conversation.

  • Posts: 27
  • Thank you received: 1
2 weeks 3 days ago #322311

Hi Philip,
Here a screenshot of the errrors on the terms&conditions page.
I just copy/paste into a text editor because the page was not completely visible in the screenshot.

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 27
  • Thank you received: 1
2 weeks 3 days ago #322316

Maybe it is possible to replace the whole Terms and Conditions shit by:
<p>Door uw betaling te voltooien, gaat u akkoord met onze <a href="index.php?option=com_content&view=article&id=19&Itemid=181" target="_new">Algemene Voorwaarden</a></p>

The only thing is: what file do I have to edit, what to replace with my html?

Please Log in or Create an account to join the conversation.

  • Posts: 2647
  • Thank you received: 348
  • MODERATOR
2 weeks 2 days ago #322315

Hello,

Have a look on the first line of your call stack :
"JROOT/templates/joostrapbase-v3-4/html/com_hikashop/checkout/termsandconditions.php:14"

This seems to indicate that you have an override, created by some or by your template.
Maybe this the root issue ? Maybe the HikaShop override view is from an too old HikaShop view ?

Anyway go to this file, and rename it like "termsandconditions0", and test to see if that solve your issue.
And if not, once again provide the error details like you already did.

Regards

Last edit: 2 weeks 3 days ago by Philip.

Please Log in or Create an account to join the conversation.

  • Posts: 27
  • Thank you received: 1
2 weeks 9 hours ago #322351

Thank you but the overrides are from your latest version.
I solved the problem by making a custom field with some html

Please Log in or Create an account to join the conversation.

Time to create page: 0.086 seconds
Powered by Kunena Forum