Cannot restrict discount to products

  • Posts: 36
  • Thank you received: 0
  • Hikashop Business
2 months 23 hours ago #315477

-- HikaShop version -- : 4.2.2
-- Joomla version -- : 3.9.15
-- PHP version -- : 7.3
-- Browser(s) name and version -- : various
-- Error-message(debug-mod must be tuned on) -- : "error"

Normally we add a discount %, and select certain products in the "restrictions" area. The system is not letting us choose products. We click th e+ by the category, and no products show, it just says "error"

**EDIT** i added product id#s to the discount in the database tables and it worked, but we still need to fix this for future.

Attachments:
Last edit: 2 months 22 hours ago by cjmicro.

Please Log in or Create an account to join the conversation.

  • Posts: 68616
  • Thank you received: 10233
  • MODERATOR
2 months 19 hours ago #315478

Hi,

This indicates that something went wrong when loading the data from the server for the category.
I would first recommend to try again after loging out and in from your backend.
It could be an issue with a user session expiration and doing this would help.
If you still have the problem, then it could be anything from another extension (like a security extension, or some HTML replacing extension breaking things as it's wrongfully detecting something where it shouldn't do anything) to a bug in HikaShop for a special case (like for example a special character not handled properly).
To be able to help, we'll need a backend access and a FTP access and a link to this thread via our contact form so that we can analyze the situation:
www.hikashop.com/support/contact-us.html

Last edit: 2 months 22 hours ago by nicolas.

Please Log in or Create an account to join the conversation.

  • Posts: 36
  • Thank you received: 0
  • Hikashop Business
3 weeks 4 days ago #316532

sent info via contact, thanks!

Please Log in or Create an account to join the conversation.

  • Posts: 68616
  • Thank you received: 10233
  • MODERATOR
3 weeks 4 days ago #316535

Hi,

So when I check the issue on your backend, I can see that the request to the server comes back with a 500 error:
monosnap.com/file/f4YKDiUrmYxJbKWhWexVoSD86UPuPd
This usually means that a PHP fatal error happened during the process of the request.
Normally, a fatal error message is sent back to the browser with information on the issue.
However, it's not the case on your website.
In that case, you need to check the PHP error log of the website for that "Fatal error" message.
Please check that (you might need to ask your hosting) and provide the Fatal error message you get so that we can better understand where the problem is coming from.

Please Log in or Create an account to join the conversation.

Time to create page: 0.058 seconds
Powered by Kunena Forum