After Update on 4.1 checkout is not working anymore

  • Posts: 60
  • Thank you received: 2
  • Hikashop Business
2 weeks 5 days ago #307370

-- HikaShop version -- : 4.1.0
-- Joomla version -- : 3.9.6
-- PHP version -- : 7.2.0


Hi,
after the update on 4.1 the checkout has a bug. After clicking final confirmation on

/index.php/ebike-uebersicht/e-bikes-ueber-25kmh/checkout/cid-4

the systems jumps back to

/index.php/ebike-uebersicht/e-bikes-ueber-25kmh/checkout/task-show

the credential for our test side I sent via the contact formular

I hope you can help

thanks and best regards
Markus

The following user(s) said Thank You: Allanis

Please Log in or Create an account to join the conversation.

  • Posts: 31
  • Thank you received: 1
2 weeks 4 days ago #307374

I am encountering the same problem.

-- HikaShop version -- : 4.1.0
-- Joomla version -- : 3.9.6
-- PHP version -- : 7.219

To be sure it's not my code, I tried:

  1. Clean install of Joomla 3.9.6
  2. Download and install HikaShop 4.1.0 (set a PayPal address to have the PayPal payment method)
  3. Create a single product and try to checkout with it.
  4. On clicking Finish, instead of jumping to PayPal, it now goes back to "checkout/task-show", as Markus mentioned.

Thanks for any assistance.

Please Log in or Create an account to join the conversation.

  • Posts: 66046
  • Thank you received: 9668
  • MODERATOR
2 weeks 4 days ago #307382

Hi,

Thank you. This comes from a patch we added yesterday for this issue:
www.hikashop.com/forum/checkout/877600-c...html?start=20#307358
I've added another patch today to fi that. Please download again the install package on our website and install it on yours and it will fix the problem.

The following user(s) said Thank You: lousyfool, nyanginator

Please Log in or Create an account to join the conversation.

  • Posts: 60
  • Thank you received: 2
  • Hikashop Business
2 weeks 3 days ago #307429

Hi Nicolas,
thanks - now it's working again.
best regards
Markus

Please Log in or Create an account to join the conversation.

  • Posts: 87
  • Thank you received: 2
  • Hikashop Business
1 week 6 days ago #307564

Hi Nicolas,

On 2 test sites the checkout doesn't move to the second step at all. Before the update Hikashop 4.1.0 ZIP from today 12 june 14:00 and 18:00 hour, both sites worked perfect in de checkout. We had never this problem. (1 local and 1 online) https://lebasport.be

The official site is not updated yet because we want receive orders.

see the attachments with the cart and shop cart step 1. We use the "cart design"

best regards,

Marius Klabers (Joomla comm. Breda NL)

Attachments:
Last edit: 1 week 6 days ago by mariussport.

Please Log in or Create an account to join the conversation.

  • Posts: 66046
  • Thank you received: 9668
  • MODERATOR
1 week 5 days ago #307580

Hi,

This looks like a different issue than what was reported on this thread.
So I'm not sure why you have that problem.
Could you provide a backend and a FTP access so that we can look into it ?
Please do so via our contact form and include a link to this thread for reference:
www.hikashop.com/support/contact-us.html

Please Log in or Create an account to join the conversation.

  • Posts: 42
  • Thank you received: 3
  • Hikashop Business
1 week 5 days ago #307619

After the latest update, with the latest patch, I can't get to the next step in the checkout.
login credentials send via mail.

Please Log in or Create an account to join the conversation.

  • Posts: 66046
  • Thank you received: 9668
  • MODERATOR
1 week 4 days ago #307638

Hi,

@WJ :
The issue comes from a strange setup of your checkout.
You've created a menu item "registration form" of the type "URL" with a URL you apparently would like for the checkout and then selected that menu item in the "force menu on checkout".
I would rather recommend that you change the type of that menu item to "HikaShop checkout", change its alias to "naar-de-ideal-kassa" and then it should work properly with the URL www.vishandelschilder.nl/naar-de-ideal-kassa
It's actually a miracle that the way you set it up didn't cause any issue until now :)

@mariussport :
Similarily, on lebasport.nl your "force menu on checkout" setting is set to the "Bestelling en Login" menu item which isn't either a hikashop type menu item but a Joomla article. Please try to use a HikaShop checkout menu item type for that "force a menu on checkout" setting. Now, I wasn't able to reproduce the issue on your website as you still have the 4.0.3, but I highly suspect that this is the problem.

In fact, with your feedbacks, I've noted on my end to add some warning in the HikaShop configuration for such situation.

The following user(s) said Thank You: MSTACE

Please Log in or Create an account to join the conversation.

  • Posts: 37
  • Thank you received: 2
  • Hikashop Business
1 week 4 days ago #307639

Hi,
I have a similar problem after update
HikaShop Business 4.1.0 [1906121151]
joomla 3.9.8
php 7.2
www.joomspirit.com

Please Log in or Create an account to join the conversation.

  • Posts: 87
  • Thank you received: 2
  • Hikashop Business
1 week 4 days ago #307641

Hi Nicolas,

Perfect now I set the "force menu to" None. The cart is working perfect till the end!
I was thinking already that way, but i was looking to "continue shopping URL" but that was nearly!
Thank you for the quick answer.

best regards, Marius

You can close this topic.

Please Log in or Create an account to join the conversation.

  • Posts: 37
  • Thank you received: 2
  • Hikashop Business
1 week 4 days ago #307642

Nicolas & Mariussport
thank you for this very effective forum
I do the same and it works again
I don't no why this configuration change
regards

The following user(s) said Thank You: mariussport

Please Log in or Create an account to join the conversation.

  • Posts: 42
  • Thank you received: 3
  • Hikashop Business
1 week 4 days ago #307654

Hi Nicolas, all sorted thanks for the quick reply!!

Please Log in or Create an account to join the conversation.

Time to create page: 0.106 seconds
Powered by Kunena Forum