404 Error Unable to access front-end after installing HikaShop Business 4.1.0

  • Posts: 7
  • Thank you received: 0
1 week 5 days ago #308334

URGENT REQUEST- SITE IS DOWN: Very tight timeline on new web site for customer.

New site using Joomla 3.9.8 and Joomlashine JSN Mall 1.0 template. Everything was working fine until installing HikaShop Business 4.1.0 and now getting 404 Error Layout default_type_standard not found when trying to access the front-end of the site.

Template - Joomlashine JSN Mall
Plugins - Akeeba Backup Pro & Akeeba Admin Tools Pro

Is HikaShop compatible with the Sun Framework used by Joomlashine?

Thanks in advance for your assistance!

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 66270
  • Thank you received: 9720
  • MODERATOR
1 week 5 days ago #308335

Hi,

HikaShop is supposed to work with any template.
And that "default type standard" layout isn't from HikaShop.
So I'm not sure your issue is related to the install of HikaShop.
Try to disable HikaShop via the Extensions->Mange->Manage menu of Joomla. If you still have the error after that, then it's not linked to the install of HikaShop.
Also, before you access that page, activate debug mode and error reporting settings of the Joomla configuration. It should display more information on where the error is coming from which will help us/you understand which extension is involved in the issue and which file. That will help in fixing the problem.

Please Log in or Create an account to join the conversation.

  • Posts: 7
  • Thank you received: 0
1 week 4 days ago #308360

It appears Hikashop Business adds 5 menu items. After making the first HikaShop menu item the default, the front-end started working. Then I went back and made the JoomlaShine JSN-Mall Home the default menu item and the front-end was then working there. IMHO there appears to be an installation issue with Hikashop but not sure why making Hikashop the default menu item corrects the issue. Unable to recreate the problem so debug doesn't show anything.

I'm going on vacation for a few days and will not have Internet access. Should be back Sunday evening and will do some more testing and respond then.

Thanks for your assistance.

Please Log in or Create an account to join the conversation.

  • Posts: 7
  • Thank you received: 0
1 week 1 day ago #308415

Ladies/Gentlemen,

Site is still down and at a meeting today with the client they suggested finding another ecommerce solution. Today we installed EShop and did not have any issues but it means they will need to retrain their staff on setting up products since they currently use HikaShop Essentials on their current site.
So this tells me the problem is an incompatibility between HikaShop and the Joomlashine JSN Mall template. When I turn on Debug there is nothing showing at the bottom of the page so that suggest it is something that is being flagged early in the load process.

Can I suggest getting Joomlashine on the phone and work on the issue together? Otherwise, I believe the client is going to request a refund because Hikashop is useless if it doesn't work with the template they have chosen. Please treat this a URGENT.

Thank you.

Please Log in or Create an account to join the conversation.

  • Posts: 66270
  • Thank you received: 9720
  • MODERATOR
1 week 23 hours ago #308424

Hi,

I think the best is that we look at the issue directly to be able to provide a solution directly.
Please provide a link to the page with the issue, a backend access and a FTP access along with a link to this thread via our contact form and we should be able to find a solution:
www.hikashop.com/support/contact-us.html

Please Log in or Create an account to join the conversation.

  • Posts: 7
  • Thank you received: 0
6 days 21 hours ago #308472

Hi, Nicolas

We are unable to provide access to unauthorized companies/individuals per company policy. This should be simple for you all to setup a test environment by installing Joomla 3.9.8, the Joomlashine JSN Mall v1.0 template and then install Hikashop 4.1.0 Business.

When we make any of the Hikashop menu items the Default menu item, the front-end loads fine. However, it we make any JSN Mall menu items the Default, we get the 404 error message and the front-end does not load. Everything was working fine until we installed HikaShop. Logic seems to point to Hikashop being the problem but it really doesn't matter who's software is at fault. It just needs to get fixed ASAP. It has been almost a week and we need some movement on this NOW and quit stalling and pointing fingers.

We do not want a Hikashop menu item to be the Default. I would suggest you contact Joomlashine and work together to resolve this ASAP or otherwise our client is going to request a refund and go with VirtueMart or other ecommerce solution that does work.

Please Log in or Create an account to join the conversation.

  • Posts: 66270
  • Thank you received: 9720
  • MODERATOR
6 days 14 hours ago #308474

Hi,

While setting up a test environment with the template on our end to try to reproduce the issue is possible, it could take a while as we don't have a copy of that template. So we'll first have to request it from JSN. And that doesn't mean we'll be able to reproduce it as something else might be at play here, especially since we don't have the layout mentioned in the error message in the code of HikaShop and thus it can't come from the code in HikaShop.
That's why I suggested an access to your website in order to rapidely look into it. That's the fastest way to go about it, actually.

I've requested a copy of the template, so we'll see, but there is a high chance that I won't be able to reproduce the problem.
What you could try in the mean time is to rename the folder templates/YOUR_TEMPLATE/html/com_hikashop/ via FTP to something else. That will deactivate the overrides of HikaShop from your template and it should hopefully fix the problem.

Last edit: 6 days 20 hours ago by nicolas.

Please Log in or Create an account to join the conversation.

  • Posts: 7
  • Thank you received: 0
6 days 13 hours ago #308497

Just as it doesn't make business sense to give me access to your network/server, it also doesn't make business sense to give HikaShop access to our corporate network since we have no idea who you are and what your vetting requirements are for you employees......so this is not an option.

This morning I downloaded Joomla 3.9.10 and installed it on a fresh version of Linux Apache server, downloaded Joomlashine JSN Mall template (for your information, this version of the template has a free 15 day trial - www.joomlashine.com/joomla-templates/jsn-mall.html ) and downloaded Hikashop Business 4.1.0. It took me less than 40 minutes to download and install everything to duplicate the error.

Just because this 404 Error is not part of HikaShop code doesn't mean that HikaShop is clean because it is when HikaShop is installed everything quits working.

If you don't want to take the extra effort to resolve this issue now, our customer is concerned you will not have the capability or expertise to resolve an issue once your product is used in production. They cannot go for a week with their web site being down waiting on someone at HikaShop to take ownership of an issue.

If this issue isn't resolved in two days, they are going to request a refund and also leave the appropriate feedback so other potential customers know what type of support to expect before purchasing your product.

Please Log in or Create an account to join the conversation.

  • Posts: 7
  • Thank you received: 0
6 days 12 hours ago #308498

You wrote "What you could try in the mean time is to rename the folder templates/YOUR_TEMPLATE/html/com_hikashop/ via FTP to something else."

There is no folder by that name in the "templates/jsn_mall/html/" folder. Could it be something went wrong during the HikaShop installation process?

Please Log in or Create an account to join the conversation.

  • Posts: 66270
  • Thank you received: 9720
  • MODERATOR
6 days 31 minutes ago #308513

Hi,

Again, it's not about extra effort, it's because I don't know the specifics of how you setup your website.
And I didn't know that they offered a 15 days trial version either and you didn't mention it until now either.
I actually took the time to get the trial version of the template and set it up on my end and unfortunately I didn't get the error.
I'm able to access all the different pages of HikaShop on the frontend and it works just fine:
monosnap.com/file/3hyTtCgWZB8JiHJvwGcvgbeSjHHBfU
So there is something else to it.
Maybe it's because of your version of PHP is different than mine, maybe you did some configuration steps I didn't do, or vice-versa.
It's seems you don't want to understand my point of view on the issue. I was just trying to hepl as best as I could by asking for an access to the website, nothing else.
We'll still try to reach out to JoomlaShine to see with them if we could look into the matter (maybe it only appears with the paid versions of the template).
I fear solving such issue where we can't reproduce the problem will be impossible in 2 days. Thus, I'm afraid we'll have to go to the refund process as I can't reproduce the issue on my end so far and you didn't provide the necessary information or access for us to be able to look into the issue in a short time period.
You can follow the instructions here if you want to proceed to a refund:
www.hikashop.com/money-back-policy.html

Please Log in or Create an account to join the conversation.

  • Posts: 7
  • Thank you received: 0
5 days 16 hours ago #308541

Nicolas,

I just got through installing EShop and VirtueMart with no issues with Joomla 3.9.10 and the JSN Mall 1.0.template. We use PHP 7.1 and MySQL 5.7. No configuration options were changed.

There is obviously an installation issue with HikaShop Business 4.1.0. Our client is currently using HikaShop Essential and wanted to stay with your product to reduce training effort, etc. However, the poor technical support received and not showing ownership of this issue is reason enough for our customer to request a refund and go with another ecommerce solution.

I think you all need to know you lost our business because you did not understand the customer perspective. When they say it is CRITICA, they are not going to wait a week for you to offer excuses and dance around the issue. You also need to understand that corporations that take security seriously are not going to give you or anyone unfettered access to their network/server. You need to be able to accept uploads if you want to see their code or be able to provide remote support instructions for their developers to help you diagnose the issue.

Bill.

Please Log in or Create an account to join the conversation.

Time to create page: 0.080 seconds
Powered by Kunena Forum