Google products XML feed issue after update

  • Posts: 399
  • Thank you received: 16
  • Hikashop Business Hikashop Multisite
5 months 2 weeks ago #310462

-- HikaShop version -- : 4.2.1
-- Joomla version -- : 3.9.12
-- PHP version -- : 7.3

Hi Hikashopteam,

Before update to 4.2.0 the xml export with GTIN code went fine.
If there was no GTIN code we have to set a FALSE value to the identifier-exist field and the xml didn't export a GTIN field.

But now after the update, the xml feed export the custom field name for the GTIN code if there is no GTIN code present in the product.

Hope you can fix this.

Kind regards,
Lumiga



Here you can see our configuration.






Kind regards,
Lumiga
Attachments:
Last edit: 5 months 2 weeks ago by Sailfin73.

Please Log in or Create an account to join the conversation.

  • Posts: 68169
  • Thank you received: 10160
  • MODERATOR
5 months 2 weeks ago #310509

Hi,

Add the code:

$column = @$plugin->params['identifier_exists'];
				if(!empty($column) && ($column == 'TRUE' || (!empty($product->$column) && $product->$column == 'TRUE')))
before the line:
$xml .= $this->_additionalParameter($product,$plugin,'gtin','gtin');
in the file plugins/hikashop/google_products/google_products.php
and it should help.

The following user(s) said Thank You: Sailfin73

Please Log in or Create an account to join the conversation.

  • Posts: 399
  • Thank you received: 16
  • Hikashop Business Hikashop Multisite
5 months 4 days ago #311013

Thanks!

Are you going to add this code also in the new update?

Kind regards,
Lumiga


Kind regards,
Lumiga

Please Log in or Create an account to join the conversation.

  • Posts: 68169
  • Thank you received: 10160
  • MODERATOR
5 months 4 days ago #311015

Yes

The following user(s) said Thank You: Sailfin73

Please Log in or Create an account to join the conversation.

Time to create page: 0.081 seconds
Powered by Kunena Forum