One time Design Fee using Global Cart Fee plugin

  • Posts: 24
  • Thank you received: 1
  • Hikashop Business
3 months 1 week ago #306365

-- url of the page with the problem -- : crestridgefarms.com
-- HikaShop version -- : HikaShop Business: 4.1.0
-- Joomla version -- : 3.9.6
-- PHP version -- : 7.1.29
-- Browser(s) name and version -- : Chrome Version 74.0.3729.131
-- Error-message(debug-mod must be tuned on) -- : None

Greetings,

I am trying to setup the Global Cart Fee. I have followed all the steps found in the various post here and I am using the plugin downloaded from this page: www.hikashop.com/marketplace/product/224-global-cart-fee.html .

What I need or am trying to do is this: We are a bakery and have the ability to make a cookie cutter out of any image using our 3D printer. The Product "Custom Cookie" will have a $20.00 USD (one time for each order) "Design Fee", which covers the cost of the 3D services. This Design Fee is on top of the cookie order. The cookie product has several variants of different prices.

My problem is, this fee from the Global Cart is being applied to every product in the store even tho I have it set to only apply to the Custom Cookie Product. Additionally the Custom Field I created to be used by the plugin is populating in the Product Listing Menu.

To clarify, I have attached screenshots of how I have completed the steps listed in the Global Cart Fee Plugin instructions, as well as what I have gleaned from the various post here.

Thank you in advance for your assistance. If there is another way to do this, them please advise.

Bill

Setup screenshots:

Product: prnt.sc/nmdxva
Variants: prnt.sc/nmdy4i
Custom Field: prnt.sc/nmdyjy
Plugin: prnt.sc/nmdyuj
Menu Item Product List: prnt.sc/nmdzc0
^^This is coming from the Custom Field, if I unpublish the Custom Field, this goes back to normal.

Shopping Cart with any product: prnt.sc/nmdzri


Regards,
Bill

Please Log in or Create an account to join the conversation.

  • Posts: 66593
  • Thank you received: 9792
  • MODERATOR
3 months 1 week ago #306367

Hi,

First, in your custom product field, you should only enter a number. So no $. Otherwise, it won't be able to process it properly.
I think that's the main issue you have here.
Also, in the settings of the global cart fee plugin, I think you want to leave the "price" field empty since it's supposed to take the value from the custom field in the product, not the value in the plugin.
Finally, in the settings of the custom field, you can see display and email display settings. You want to turn them all off except the "backend form" one so that you can see the field when you edit the products.

Please Log in or Create an account to join the conversation.

  • Posts: 24
  • Thank you received: 1
  • Hikashop Business
3 months 1 week ago #306388

Thanks Nicolas, i'll give it a go in a bit. Will report back

Bill


Regards,
Bill

Please Log in or Create an account to join the conversation.

  • Posts: 24
  • Thank you received: 1
  • Hikashop Business
3 months 1 week ago #306407

Greetings Nicolas,

No joy mate, it still adds the fee to any item in the store... :-(. If you would like backend access, let me know.

regards,
Bill


Regards,
Bill

Please Log in or Create an account to join the conversation.

  • Posts: 66593
  • Thank you received: 9792
  • MODERATOR
3 months 1 week ago #306493

Hi,

Enter the character "+" in the "price" field of the plugin. That way, the price of the additional fee will be 0 by default and will be the value of the custom field in the product if any. That should do it.

Please Log in or Create an account to join the conversation.

  • Posts: 24
  • Thank you received: 1
  • Hikashop Business
3 months 1 week ago #306494

Hi Nicolas,

Still no joy, but it is NOT adding the $20.00 to every product, just not adding it when it's supposed to: prnt.sc/nnzn0t

prnt.sc/nnznpy

Bill


Regards,
Bill

Please Log in or Create an account to join the conversation.

  • Posts: 66593
  • Thank you received: 9792
  • MODERATOR
3 months 1 week ago #306496

Hi,

Did you enter the number you want as price in the custom field "cutterdesign" in these products ?
I don't see any other possibility for it to not work.

Please Log in or Create an account to join the conversation.

  • Posts: 24
  • Thank you received: 1
  • Hikashop Business
3 months 1 week ago #306526

Yes, sorry I should have posted this screenshot as well: prnt.sc/nocx8v

If you want/need backend access, it's not a problem.

Bill


Regards,
Bill

Please Log in or Create an account to join the conversation.

  • Posts: 66593
  • Thank you received: 9792
  • MODERATOR
3 months 6 days ago #306529

Hi,

That's a screenshot of the settings of the custom field. I'm talking about the custom field you see when you edit the product in the backend. For example, on our demo website:
monosnap.com/file/d4AKiq98PEmGN6Mw7J81c3WenCQwDx

Please Log in or Create an account to join the conversation.

  • Posts: 24
  • Thank you received: 1
  • Hikashop Business
3 months 6 days ago #306540

sorry, yes that is populated prnt.sc/nojndp


Regards,
Bill

Please Log in or Create an account to join the conversation.

  • Posts: 66593
  • Thank you received: 9792
  • MODERATOR
3 months 6 days ago #306549

Hi,

I see that you have variants for your product so make sure that you also fill that field for the variants for the product.

Please Log in or Create an account to join the conversation.

  • Posts: 24
  • Thank you received: 1
  • Hikashop Business
3 months 6 days ago #306559

It is filled in for each variant, prnt.sc/nou0sf


Regards,
Bill

Please Log in or Create an account to join the conversation.

  • Posts: 66593
  • Thank you received: 9792
  • MODERATOR
3 months 5 days ago #306565

Hi,

Then please provide a backend and a FTP access access along with a link to this thread via our contact form so that we can have a look at the situation as it works fine for me on my end with the same setup.
www.hikashop.com/support/contact-us.html

Please Log in or Create an account to join the conversation.

  • Posts: 66593
  • Thank you received: 9792
  • MODERATOR
3 months 4 days ago #306635

Hi,

I was able to understand the issue with the access.
The issue comes from the way you configured the custom field and the product.
You set the custom field with a default value of 20, but didn't actually save the value of the custom field in each variant of the product.
I've done it for you for a few variants that I tried with and also removed the value from the main product (to avoid doubling the fee) and it seems to be working fine. So check all the variants of the product and save them once with the correct value in that field and then do your tests. It should be much better.

Please Log in or Create an account to join the conversation.

  • Posts: 24
  • Thank you received: 1
  • Hikashop Business
3 months 3 days ago #306701

Hi Nicolas,
Sorry for the delay in responding, we had a massive order to get out for a University graduation. I have done as you requested and it's all good now. Thank you ever so much for your time and assistance.

Bill


Regards,
Bill

Please Log in or Create an account to join the conversation.

  • Posts: 12086
  • Thank you received: 1666
  • MODERATOR
3 months 1 day ago #306718

Hello Bill,

Thanks for your feedback !

Kind regards,
Mohamed.

Please Log in or Create an account to join the conversation.

Time to create page: 0.086 seconds
Powered by Kunena Forum