Bug with Brand category display

  • Posts: 156
  • Thank you received: 8
  • Hikamarket Multivendor Hikashop Business
3 months 1 week ago #306555

-- HikaShop version -- : 4.1.0
-- Joomla version -- : 3.9.6
-- PHP version -- : 7.1.29
-- Browser(s) name and version -- : Firefox, Chrome, Safari
-- Error-message(debug-mod must be tuned on) -- : 404 Category not found

Hello,

I have an issue when trying to display the brand listing in
- menu
or
- modules
The error is 404 Category not found, all other categories are displayed correctly in menus and modules.

- There is no canonical url
- When I click on the brand name in the product page I am redirected to the correct url, brand page + product listing
- When I click on the menu category listing ( catgeory: brand) I get a 404 Category not found
- If I publish a module ( on any page ) that is linked to the Brand category the same 404 Category not found displays

Any hint or solution?

Please Log in or Create an account to join the conversation.

  • Posts: 156
  • Thank you received: 8
  • Hikamarket Multivendor Hikashop Business
3 months 1 week ago #306556

I am now getting the same 404 error on a page that was previously correctly displaying before updating to 4.1.0

This is happnening on categories that are outside the main product category

Root
- Product categrory (ok)
- - Product cat 1 (ok)
- - ...
- Brand (404)
- - Brand A (ok from product page button link)
- Discounts (404)
- - Discount 5%
-- ...

Last edit: 3 months 1 week ago by pprle.

Please Log in or Create an account to join the conversation.

  • Posts: 66630
  • Thank you received: 9809
  • MODERATOR
3 months 1 week ago #306557

Hi,

It's hard to say what is the problem without more information on the issue.
Could you provide the links of the pages you're talking about ?

The error category not found probably comes from the Joomla router as it thinks the URL is a Joomla category URL and not a HikaShop URL. So it's something linked to the menu item settings and / or the SEF settings of the HikaShop configuration (so screenshots of these would help too).
I don't see why it would be linked to the update of HikaShop. Which version did you use before the update ?

Please Log in or Create an account to join the conversation.

  • Posts: 156
  • Thank you received: 8
  • Hikamarket Multivendor Hikashop Business
3 months 1 week ago #306593

Hello Nicolas,

The menu alias is "brands"
The menu, joomla sef, hikahsop sef settings can be seen in the screenshots

This message contains confidential information

Joomla admin is he same as given front-end credentials Bug-Squad

PS: MijoSQL is installed if needed.
[/confidential]

Attachments:
Last edit: 3 months 1 week ago by pprle.

Please Log in or Create an account to join the conversation.

  • Posts: 66630
  • Thank you received: 9809
  • MODERATOR
3 months 1 week ago #306608

Hi,

In the "brands" element (that you can edit by clicking on the "root" element of the left menu when in the Products>Categories menu, you set the "access level" to "none". Because of that the access to the brands main listing is disabled:
monosnap.com/file/IaMIhXCTvUQlEgrceFtPjRkDErnd6R
You want to set that to "all" if you want people to be able to access brands.

Please Log in or Create an account to join the conversation.

  • Posts: 156
  • Thank you received: 8
  • Hikamarket Multivendor Hikashop Business
3 months 1 week ago #306664

Thank you Nicolas,

Could it be that after an update and by clicking (or not - but I did...) on "rebuilt categories" setting are changed in the categories.

I am thinking about this because the other categories (donatation, subscription, event, serials) are also back to none (access level)
and also a weird thing happened the badges and discount catgeory was unpublished...

Please Log in or Create an account to join the conversation.

  • Posts: 66630
  • Thank you received: 9809
  • MODERATOR
3 months 1 week ago #306665

Hi,

No, the update wouldn't change that setting, nor the published state of categories.
Your issue was caused from a fix that we added in the 4.1.0 to properly check the access level of categories/brands in some cases as it didn't check the access levels in some configurations.
So you already had the issue for a long time be didn't see it as the check wasn't done properly.

Please Log in or Create an account to join the conversation.

Time to create page: 0.061 seconds
Powered by Kunena Forum