There are currently no items in this category

  • Posts: 3
  • Thank you received: 0
3 months 1 week ago #308333

I am using the menu item type "Categories listing" to display products on a page. I am getting the message "There are currently no items in this category." But there are products under the category.

www.salusglobal.com/salus-global-insights

At the same time I am using hikashop module on a different page to show the extra same category(products). This page is displaying the products fine.

www.salusglobal.com/store-teams

The only thing I can find comparing the two pages is the hikashop.js file on the component(menu) page that is not working loads the hikashop.js file before jquery.min.js. The module page loads the hikashop.js file after jquery. Not sure if this would cause the problem but it is the only difference I can fine.

Thanks for your help.

Please Log in or Create an account to join the conversation.

  • Posts: 67109
  • Thank you received: 9946
  • MODERATOR
3 months 1 week ago #308337

Hi,

There is no error message "There are currently no items in this category." in HikaShop. Are you sure that this error message comes from HikaShop ? Or maybe you changed the default message with a translation override or some customization ?
The error message displayed by HikaShop when no products are found for a category is "No products found.".
Could you provide screenshots of the settings of the menu item "salus-global-insights " ?

Please Log in or Create an account to join the conversation.

  • Posts: 3
  • Thank you received: 0
3 months 1 week ago #308361

Here are some screenshots.

I didn't build the site, just took over the admin. I see under the template area there is custom changes to com_hikashop->category->listing.php. The custom changes are from version 3.0.0. Maybe the changes are no longer working with 4.2.0. I will have to compare files to see if I can find the issue.

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 67109
  • Thank you received: 9946
  • MODERATOR
3 months 1 week ago #308363

Hi,

I don't think it's related to the 4.2.0. However, it's probably related to your view override not compatible with recent versions of Joomla.
One year ago, we had to add modifications in the view file category/listing.php for a new version of Joomla at that time. So if you have a view override from the 3.0.0 on that file the problem is likely from there.
So check for the file templates/YOUR_TEMPLATE/html/com_hikashop/category/listing.php via FTP and if you find it, try renaming it to deactivate it. That could very well fix the problem.

Please Log in or Create an account to join the conversation.

  • Posts: 3
  • Thank you received: 0
3 months 5 days ago #308401

Thanks for the information. I will test it out, but I assume you are correct and the overwrite file needs to be updated with the newer version.

Please Log in or Create an account to join the conversation.

Time to create page: 0.059 seconds
Powered by Kunena Forum