Product images not showing on Firefox and Chrome but just fine on Safari

  • Posts: 89
  • Thank you received: 3
  • Hikashop Business
3 weeks 3 hours ago #309438

-- url of the page with the problem -- : www.stutteringtherapyresources.com/store
-- HikaShop version -- : 4.2.1
-- Joomla version -- : 3.9.1
-- Error-message(debug-mod must be tuned on) -- : You don't have permission to access /media/com_hikashop/upload/thumbnails/150x150f/school_age_cover.webp on this server.

Hello. The product images in my store show a broken link when viewing in Firefox and Chrome but work just fine in Safari.

Here is an example page:
www.stutteringtherapyresources.com/store...py-a-practical-guide

When I copy the link for the image, I see:
www.stutteringtherapyresources.com/media...chool_age_cover.webp

If I try to go directly to that URL, I get a 403 Error
Forbidden. You don't have permission to access /media/com_hikashop/upload/thumbnails/350x300f/school_age_cover.webp on this server.

Again, this does not happen in Safari - it works just fine. I can see all of the files when I use a file manager. And, the folder and images are all set to 755 (I tried 644 for the images first).

I don't know how long this has been happening, since I use Safari. This seems to be relatively recent, however (perhaps started in the past few weeks).

Help? Thank you! Scott

Please Log in or Create an account to join the conversation.

  • Posts: 238
  • Thank you received: 26
  • Hikamarket Multivendor Hikashop Business
2 weeks 6 days ago #309447

Please Log in or Create an account to join the conversation.

  • Posts: 89
  • Thank you received: 3
  • Hikashop Business
2 weeks 6 days ago #309456

Thanks. The issue is not related to admintools - it's just that that utility provides an easy way to generate .htaccess files. The issue was the need to allow the webp image generation.

Ultimately, though, I had to turn off the webp images (only temporarily, I hope), because I got black stripes on my images in chrome and Firefox (but not safari) when it was using webp, and I don't get those with png (which are transparent). Alas. A long time figuring out what the problem is only to find that I can't use the feature anyway because of that.

If there's a way to get that black stripe turned off on the webp images, then that would be a help, too. Thanks.

Please Log in or Create an account to join the conversation.

Time to create page: 0.069 seconds
Powered by Kunena Forum