Title in variations in other languages

  • Posts: 40
  • Thank you received: 1
  • Hikashop Business
1 week 4 days ago #314660

-- HikaShop version -- : 4.2.2
-- Joomla version -- : 3.9.14
-- PHP version -- : 7.3
-- Browser(s) name and version -- : xxx

Hi,

I have to correct myself The translations of the variations are made correct in Characteristics. All variations for all products are the same.

1 - 9 singers
10- 20 singers
21 -30 singers
etc etc total 12 variations.

He already made 350 products and now is seeing that in all other languages the variation is the title of the product and not the amount of singers. That would mean he has to change the name field in 12600 variations. ( 350 x 3 languages x 12 variations.)

It seems that something is going wrong but I can't see what. If I make a new product the variations are translated correctly.

****Edit. The name field of the variation causes the fault ***

Kind Regards,
Raoul

Attachments:
Last edit: 1 week 3 days ago by gielhier.

Please Log in or Create an account to join the conversation.

  • Posts: 67916
  • Thank you received: 10111
  • MODERATOR
1 week 3 days ago #314661

Hi,

What I would recommend is to run a MySQL query to delete all the product_name translations of variants from the #__falang_content table as well as empty the product_name of the variants in the #__hikashop_product table.
That way, the system would dynamically use for the name of the selected variant :
the translated name of the main product + the translation of the characteristic value

So you'll want to run such queries :
UPDATE #__hikashop_product SET product_name = '' WHERE product_type != 'main';
DELETE #__content_falang WHERE reference_table = 'hikashop_product' AND reference_field = 'product_name' AND reference_id IN (SELECT product_id FROM #__hikashop_product WHERE product_type!='main');

Note that I've written this from the top of my head and it is not tested. So make sure you do a backup fo the database so that you can restore it if it doesn't work or if the result is not to your liking. Also, you'll need of course to change #__ by the table prefix of your website.

Please Log in or Create an account to join the conversation.

  • Posts: 40
  • Thank you received: 1
  • Hikashop Business
5 days 8 hours ago #314826

Hi,

We now found out what the problem is. If you copy a product several times it automatically fills in the name field of the characteristics. Why does this happen? The solution you gave tot empty the name fields is out of our expertise. Can you help us with that?

Regards,
Raoul

Please Log in or Create an account to join the conversation.

  • Posts: 67916
  • Thank you received: 10111
  • MODERATOR
4 days 23 hours ago #314835

Hi,

I just tried to reproduce the issue on my end but I'm not able to. When I copy a product without the name field filled in the variants, it's not filled either in the copy of the product. I tried to also copy the copy, and copy the products several times, but I'm still not able to see any issue.
So there must be something else to it.
Could you provide a screenshot of the main product and one variant before the copy, and same on the copy with the issue so that we can better understand the situation ?

If you want to just empty the name fields of the variants, you can do that with a mass action via the menu System>Mass actions. Just run a mass action with a filter on the product type to only affect the variants, and then use an action "update the values" on the product_name column without any value and it will empty the name of the variants.
Supposing that you also have Falang translations for the variant name (which I'm not sure that's the case?), then I'm afraid it will require the deletion via your PHPMyAdmin. Please understand that such support is not included even more so if it's for another extension. So we would have to bill you an extra for that operation. But first we need to make sure of what is your issue.

Please Log in or Create an account to join the conversation.

  • Posts: 40
  • Thank you received: 1
  • Hikashop Business
4 days 4 hours ago #314888

Hello Nicolas,

To explain the problem I made a screencast.

totoweb.nl/images/support/title-problem.mp4

In my opinion you should be able to fill in the name fields of the product in another language. These could be different. In copy 4 it just works but as soon as you copy the product the name fields of the variants are filled in with the title in the translated name field of the product.
Because the client left the variants untouched and only made copy's he discovered to late that those name fields now are filled in and can't be removed.

Kind regards,
Raoul

Please Log in or Create an account to join the conversation.

  • Posts: 12284
  • Thank you received: 1694
  • MODERATOR
3 days 7 minutes ago #314929

Hello Raoul,

We successfully reproduced it, so we'll try to debug and test it on our end and get back to you a soon as possible.

Thank you for your feedback.
Kind regards,
Mohamed.

Please Log in or Create an account to join the conversation.

  • Posts: 40
  • Thank you received: 1
  • Hikashop Business
2 days 7 hours ago #314967

Hello Mohammed,

I also asked Stéphane from Falang to look in to the problem. Maybe you want to contact him also? This is his answer>

Hi,

I have start to look at your problem , i Don't have solution it's a mix of hikahsop and falang problem.
Hikashop make the content element for Falang and have integrated it directly in hikahsop (it's not like quickjump from Falang)

When i look in the falang component , i can see the product but not the variant or caracteristique.
When i try to edit for copy 5 the variant for 10-20 zangers
i have this name for English "Rocking Billy Engels 4" but i can't remove it , when i save it's came back. but it's seem to work if i put the translation 1-9 singers

i think there are a problem in the copy button from hikahsop and variants with translation. a problem when you try to remove the variants name.

Did you try to write to hikahsop team too ? it's a mix of support of ours 2 products, of course they can write me.

Stéphane

Please Log in or Create an account to join the conversation.

  • Posts: 12284
  • Thank you received: 1694
  • MODERATOR
6 hours 12 minutes ago #315027

Hello Raoul,

We succeed to reproduce it on our end and made a fix, can you download the last Hikahop version through our website, install it and test it again ? Thank you.

Kind regards,
Mohamed.

Please Log in or Create an account to join the conversation.

Time to create page: 0.067 seconds
Powered by Kunena Forum