Price excluding tax not calculatet if setting up product price

  • Posts: 13
  • Thank you received: 1
  • Hikashop Business
1 week 3 days ago #322528

-- HikaShop version -- : 4.3.0
-- Joomla version -- : 3.9.20
-- PHP version -- : 7.2
-- Browser(s) name and version -- : Any
-- Error-message(debug-mod must be tuned on) -- : None

HI

I have a tax category for public and registered users. Tax is 7.7%.

If I add product price including 7.7% tax for Public and Registered users, in second price field price without tax does not get added. Instead price including tax is added again. Please see screenshot.

How can I solve this?

Thanks.

Patrick

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 12481
  • Thank you received: 1716
  • MODERATOR
1 week 2 days ago #322533

Hello,

Your issue is probably coming from the fact that you didn't set any tax rate through your tax category. Can you show us through some screenshots how you configured your tax category and rate ? Thank you.

Kind regards,
Mohamed.

Please Log in or Create an account to join the conversation.

  • Posts: 13
  • Thank you received: 1
  • Hikashop Business
1 week 2 days ago #322571

Hello Mohamed and thanks.

I have set tax categories and rates of 7.7% for public and registered users and tax 0.0% for companies.

Please see screenshots.

Thanks.

Patrick

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 70194
  • Thank you received: 10508
  • MODERATOR
1 week 7 hours ago #322602

Hi,

You restricted your tax rule to only some user groups.
So if the user account you're using in your backend is not in one of these user groups, then it won't see that tax rule and thus the corresponding tax rate won't apply.
Also, I can see that your tax rule is restricted to Switzerland. So it's also possible that the tax rule is discarded as the default address of your user is not in Switzerland, or your "main tax zone" setting in the HikaShop configuration is not Switzerland.

The following user(s) said Thank You: pat01

Please Log in or Create an account to join the conversation.

  • Posts: 13
  • Thank you received: 1
  • Hikashop Business
1 week 3 hours ago #322614

Hi Nicolas

I now added backend user to the corresponding user group. Additionally I removed zone Switzerland (because backend user has no address).

Now it works.

Thanks a lot!

Patrick

Please Log in or Create an account to join the conversation.

Time to create page: 0.070 seconds
Powered by Kunena Forum