Voting problem

  • Posts: 369
  • Thank you received: 14
  • Hikaauction Standard Hikamarket Multivendor Hikaserial Subscription Hikashop Business
1 week 3 days ago #322508

-- HikaShop version -- : 4.3.0

Hi, I have a strange problem voting on the product. The vote will not be reflected and if I delete the review, the vote will be reflected as a negative value. I also want to ask if there is an event after the vote is updated as with the filters: window.Oby.registerAjax('filters.updated',function(params){});

Attachments:
Last edit: 1 week 3 days ago by neo191987.

Please Log in or Create an account to join the conversation.

  • Posts: 70194
  • Thank you received: 10508
  • MODERATOR
1 week 3 days ago #322543

Hi,

Hard to help you here without looking at the situation on your website, especially since the page is heavily customized.
Could you provide a screenshot of the settings of the votes in your HikaShop backend configuration page ?
And if you try the same with the default Joomla template (so without the customizations) does it work fine ?

Please Log in or Create an account to join the conversation.

  • Posts: 369
  • Thank you received: 14
  • Hikaauction Standard Hikamarket Multivendor Hikaserial Subscription Hikashop Business
1 week 3 days ago #322549

Hi, I tested with a clean installation and installed demo of Hikashop, unfortunately the result is the same.


After the vote

After deleting the vote


Joomla 3.9.20 / HikaShop Business 4.3.0 [2007271529] / PHP 7.3.20 / XAMPP for Windows

Attachments:
Last edit: 1 week 3 days ago by neo191987.

Please Log in or Create an account to join the conversation.

  • Posts: 70194
  • Thank you received: 10508
  • MODERATOR
6 days 23 hours ago #322633

Hi,

Thanks for the feedback. I better understand what is going on. I didn't had the time to look into it today, but I'll work on that tomorrow and keep you posted on my findings.

The following user(s) said Thank You: neo191987

Please Log in or Create an account to join the conversation.

  • Posts: 70194
  • Thank you received: 10508
  • MODERATOR
5 days 8 hours ago #322696

Hi,

I was able to reproduce the issue on my end and made a patch for it. It seems to work much better now.
Please download again the install package of the 4.3.0 on our website and install it on yours and it will add the patch.
It will of course be included in the next version of HikaShop.

The following user(s) said Thank You: neo191987

Please Log in or Create an account to join the conversation.

Time to create page: 0.085 seconds
Powered by Kunena Forum