Vendor Order Notification Emails Show Language Constants/Namekeys Only

  • Posts: 7
  • Thank you received: 1
  • Hikamarket Multivendor Hikashop Business
4 months 3 weeks ago #301977

-- HikaShop version -- : 4.0.1
-- HikaMarket version -- : 3.0.0
-- Joomla version -- : 3.9.1
-- PHP version -- : 7.1.25
-- Browser(s) name and version -- : Firefox 64.0

After cloning production site to a dev/test site, we just upgraded from 2.1.1 (Hikashop 3.5.1) to the following:

HikaMarket build: com_hikamarket_multivendor_v3.0.0_2018-12-14_00-52-46.tar.gz
HikaShop build: com_hikashop_business_v4.0.1_2018-12-14_00-52-12

Our vendor's market order status notification email is now only showing the Language constants/namekeys, and not the actual translations. See attached screenshot.

Joomla and Hikashop are set for English Only, and we have overrides all set within Hikashop.

In HikaMarket, I noticed that other languages are enabled and can be edited -- I don't see how to disable them -- we would like to disable -- all languages other than English are blank in the override section.

When I make a change in HikaShop English override, the changes appear in HikaMarket English Override, which I think is normal and expected, right?

We have always used the core language features, never Falang and never Joomfish. We have continued to leave "Translation published by default" set to "No". Would like to continue as before unless directed otherwise by you. Prefer to avoid another plugin even if extra hoops needed to jump through.

Is there an additional config setting I'm missing? Or an issue/bug because those other languages are enabled in HikaMARKET? Thanks in advance for any help or direction.

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 65706
  • Thank you received: 9590
  • MODERATOR
4 months 3 weeks ago #301981

Hi,

This indicates that there is some kind of error in some translation file which prevents Joomla from loading these translation keys.
You'll have to activate the "debug language" setting of the Joomla configuration. Then, go in the HikaMarket pages and at the bottom, you'll find some language debug information which should tell you which line of which file has a problem.

Please Log in or Create an account to join the conversation.

Moderators: Obsidev
Time to create page: 0.056 seconds
Powered by Kunena Forum