Shipping Invoice missing custom fields, need 1 per vendor

  • Posts: 12
  • Thank you received: 0
  • Hikamarket Multivendor Hikashop Business Hikashop Essential
2 weeks 2 days ago #312543

-- HikaShop version -- : 4.2.1
-- HikaMarket version -- : 3.0.2
-- Joomla version -- : 3.9.12
-- PHP version -- : 7.2.22
-- Browser(s) name and version -- : Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/77.0.3865.120 Safari/537.36

See attached. Order shows all custom fields. Shipping invoice does not.

And... each vendor gets an email with their items but not the other vendor.

We'd like to have shipping invoices that we generate from the backend for EACH vendor... and have all custom fields included.

We're also experiencing some custom fields now showing in vendor emails. Not every time, and no pattern to it that I can discover. Seems to be random. i know there were issues in 3.0.1 Hikamarket, we're running 3.0.2

Please advise if this takes some custom coding... glad to pay. Thanks.

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 23797
  • Thank you received: 3689
  • MODERATOR
2 weeks 2 days ago #312574

Hello,

Would it be possible that the fields with the issue are only item fields related with a product field (for the list of possible values) ?

In the backend, you can access to the vendor sub orders by clicking on the list (U9E6T31 in your screenshot).
By displaying the sub order you can generate the shipping invoice for that element.

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

  • Posts: 12
  • Thank you received: 0
  • Hikamarket Multivendor Hikashop Business Hikashop Essential
2 weeks 23 hours ago #312633

Hi Jerome.. yes! See attached. The fields that aren't getting into the shipping invoice, and sometimes are missing from emails to vendors are those that are Item - single dropdown that are paired with product - multiple dropdown. Specifically... color, waist size, size, logo values.

The attached shows all custom fields.

I'm afraid I don't understand the connections between item custom field and product custom field ... how can we make sure that the values for these fields gets into emails to vendors AND the shipping invoice.

Thank you for the note on how to find shipping invoice per vendor. I should have figured that one out!

David

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 23797
  • Thank you received: 3689
  • MODERATOR
2 weeks 5 hours ago #312690

Hello,

Would it be possible to know where is the custom field display issue exactly ?
HikaMarket does load the full order via the HikaShop order API ; so the custom field values should be correct, but maybe the context must be forced.
Knowing where is that "product listing" exactly will help to target the code and find how to solve the issue.

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

  • Posts: 23797
  • Thank you received: 3689
  • MODERATOR
1 week 1 day ago #312840

Hello,

I take a look at your test website and I was able to perform some tests.

For what I could see, your issue is not related to HIkaMarket since we can see the same display issue within an HikaShop order (not only in the HikaMarket sub-orders). Since the display is identical, what you can see in vendor orders is just a duplicate of what you can have in customer orders.

In the classical HikaShop invoice, we can see a problem with the display of item fields (where values are in a product field) ; only the last element was display fully.
It might be a problem in the HikaShop invoice view ; but I admit that it's possible that the front-end HikaMarket invoice do have the same issue (since the code for the invoice in HikaShop and HikaMarket are very similar).

Regarding the "PDF Invoice" plugin ; there is no display of item fields but the current code in the plugin should display it.
By enabling/disabling the plugin, I was able to compare the result between the HikaShop invoice and the generated PDF invoice.
So I don't know if you do have an old version, if you do have a customization or if it's a bug.
The HikaShop support team would be able to tell you more about it. But since I was not able to see "classical" item field in the PDF invoice, I do have the feeling that it's not related to the item+product system. You do have some orders with text item fields and they are not displayed in the PDF invoice either.

Because the problem is also in HikaShop orders, I do think that it will be better to open a new thread in the HikaShop section of the forum but HikaMarket do not interact with it. The patch should be first in HikaShop.

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

Moderators: Obsidev
Time to create page: 0.072 seconds
Powered by Kunena Forum