Custom Field creates separate order in ShipStation

  • Posts: 20
  • Thank you received: 0
  • Hikamarket Multivendor Hikashop Business Hikashop Essential
4 weeks 17 hours ago #324145

-- HikaShop version -- : 4.2.1
-- HikaMarket version -- : 3.0.2
-- Joomla version -- : 3.9.21
-- PHP version -- : 7.2.32
-- Browser(s) name and version -- : Chrome Version 85.0.4183.102
-- Error-message(debug-mod must be tuned on) -- : none

Not sure if best addressed to Philippe or Jerome. We have three vendors set in Hikamarket, hikashop set up so that customer sees a single order even if items are from separate vendors. However Hikamarket does create separate orders for the vendors. All that on the webserver/Hikashop works fine.That's how we want it.

Problem:

We installed and configured the Shipstation plugin, and... your new plugin to enable a fee for a custom field. When orders get to Shipstation, regardless of the number of vendors in a customer total order... ie, if a single vendor, or more, if the customer has chosen the custom field to add embroidery or a logo to a product... shipsstation creates another order JUST for that custom field.

If I change shipstation plugin to only do one order ... then both vendors are combined in shipstation but the custom field is a separate order.
If i leave shipstation setting to multiple orders... I will see an order for each vendor, that's how we want it, but also that third (or fourth depending on number of vendors) order is JUST for the custom field. How can we stop creation of separate order for custom field? As usual I'm happy to pay for help, did not know who I should send to ... or both Philippe and Jerome.

Please Log in or Create an account to join the conversation.

  • Posts: 2779
  • Thank you received: 358
  • MODERATOR
4 weeks 3 hours ago #324157

Hello,

Maybe there is a side effect in this specific configuration, and so we have something to correct because from what you describe we have an issue.

Can you precise these elements, please :
1. Does you refer to this plugin, here
2. Can you provide your relative Custom field configuration AND your custom field fee plugin (via a screenshot).
3. Active the Shipstation debug mode and provide the log file (via our Contact us form with an url link to this topic in your message please).

These elements will allow us to better understand the situation, and find a solution.
Awaiting news from you

Regards

Last edit: 4 weeks 4 hours ago by Philip.

Please Log in or Create an account to join the conversation.

Moderators: Obsidev
Time to create page: 0.056 seconds
Powered by Kunena Forum