trying to upgrade joomla 3 to 4, but several modules from hika seems old?

  • Posts: 80
  • Thank you received: 1
  • Hikashop Essential
1 year 5 months ago #349350

-- url of the page with the problem -- : localhost // avirus.dk
-- HikaShop version -- : Essential: 4.7.1
-- Joomla version -- : 3.10.11
-- PHP version -- : 8.1
-- Browser(s) name and version -- : ff 110
-- Error-message(debug-mod must be tuned on) -- : See images belov
3 from backend.
1 from frontend

Trying to opgrade my site is from 1.5-2.5-3 and now trying to upgrade til j4.
Have disablet many externsions, that seems old, but its in joomla ??
but now...
I´m trying to see what i can do, before i´m upgrading my real site.
But it seems to be some old extensions/modules. how can it be from hikashop, some is from 2016 ??
I have used hikashop for some years now, and im glad for the software :-)

Regards

Please Log in or Create an account to join the conversation.

  • Posts: 82048
  • Thank you received: 13190
  • MODERATOR
1 year 5 months ago #349351

Hi,

The error messages you posted in the HikaShop Affiliate plugin means that the version of this plugin you have is not compatible with Joomla 4.
However, this plugin is only included in HikaShop Business and I can see that you're using the Essential edition of HikaShop.
So I suppose you have a really old version of the HikaShop Affiliate plugin which was not updated for a long time because it's not in the Essential edition.
I'm not sure why this plugin ended up on your website. I know some template starter pack had wrongfully included HikaShop Business instead of the Starter edition in the past. So it could be a reason. Or it could be that you got an illegal version of the Business edition in the past in order to try it out before purchasing the Essential edition for us and installing it over the Business edition.
Regardless of the reason, this plugin won't do anything with an Essential edition, so you can just disable and / or uninstall it. It won't change anything to what your website was doing before and it will remove the error messages you posted.

Regarding the error with the acymailingtoolbox system plugin, it's also an old plugin, but it's apparently a plugin from AcyMailing. I suppose you want to disable it. But the best will be to check with AcyMailing's support what they recommend as I don't know what that plugin is/was for.

Please Log in or Create an account to join the conversation.

  • Posts: 80
  • Thank you received: 1
  • Hikashop Essential
1 year 5 months ago #349363

I doesent have any illegal version, but maybe i had have the business version, end later the essential version.

So. I can just uninstall alle version, within name hika, with older version than 4.x.x ??

And the installation still vil work?

Regards.

Please Log in or Create an account to join the conversation.

  • Posts: 82048
  • Thank you received: 13190
  • MODERATOR
1 year 5 months ago #349367

Hi,

It will still work. However, note that third party plugins made for HikaShop (like the plugins available on our marketplace) might have "hika" in their name, but they have their own version different from HikaShop.
Only the plugins included in HikaShop have the same version as HikaShop.
For example, the HikaShop PDF invoice plugin ( www.hikashop.com/marketplace/product/18-plugin-pdf.html )'s latest version is the 1.2.1. It has "hika" in its name, and it is not included by default in any edition of HikaShop. You can disable it and HikaShop will still work, however it won't generate the PDF invoices anymore.
So indiscriminately disabling all the plugins with "hika" and a version different from 4.7.1 won't break HikaShop but it might remove some feature you're actually using on your shop.
However, that's a good place to start to make sure you have the latest version of these plugins and check whether you're actually using them or not, to do some clean up.

Please Log in or Create an account to join the conversation.

Time to create page: 0.071 seconds
Powered by Kunena Forum