Vendor page empty on front end

  • Posts: 103
  • Thank you received: 0
  • Hikamarket Multivendor Hikashop Business
1 year 1 month ago #298544

-- url of the page with the problem -- : www.tweedehandjes.com
-- HikaMarket version -- : 2.1.1

HI,

Several times per month I get a message from my vendors that they cannot see their products on their vendor page on the front end.
They login and all they see is "Verkoper account" (Vendor account). The rest of the page is empty. See attached.
Normally they would see their orders, their products and the outstanding payable amount.

Then, when i save their vendor account in the backend and clear cache, it works again. But I would like to know a solution to this issue.
It seems to me that it is not normal that I have to keep on saving and clearing cache in order for my vendors to see their account.

Thanks in advance.

Regards,
Joyce

Attachments:
Last edit: 1 year 1 month ago by joycehoveling.

Please Log in or Create an account to join the conversation.

  • Posts: 23806
  • Thank you received: 3692
  • MODERATOR
1 year 1 month ago #298558

Hello,

Right now, all I can tell you is that you should not cache HikaShop and HikaMarket pages.
I don't know how the cache could store an empty page ; but since the content of the page is dynamic (the reports), they shouldn't be store in the cache at all.

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

  • Posts: 103
  • Thank you received: 0
  • Hikamarket Multivendor Hikashop Business
1 year 1 month ago #299169

Hi Jerome,

I've tested again without caching, but the result is the same.
Today I again received an e-mail from a vendor who coulf not see the details in her vendor account.
I needed to save the account in order for her to see the details again.

This is not a known bug to you?
What info do you need from me in order to investigate this?

Kind regards,
Joyce

Please Log in or Create an account to join the conversation.

  • Posts: 23806
  • Thank you received: 3692
  • MODERATOR
1 year 1 month ago #299180

Hello,

What "account" did you have to saved ?
I would need to understand how your vendor structure is made ; if you have subscription or something which can interact with HikaMarket and would explain why you need to save the "account" to restore the display of the vendor page.
If you need to perform that action, it means that something else happened and result of that blank page.
Unfortunately, it is not a known issue so HikaMarket 3.0 would not have a fix for that.

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

  • Posts: 103
  • Thank you received: 0
  • Hikamarket Multivendor Hikashop Business
1 year 2 days ago #300619

Hello,

Could you please help me on this?
None of my vendors can log on to their accounts to be able to see their products.
The vendor control panel is empty when they log in.

I do not know how to fix this.
What info do you need from me in order to assist me?

This is the link of vendor control panel I mean:
index.php?option=com_hikamarket&view=vendormarket&layout=cpanel

In the front end the link is this:
www.tweedehandjes.com/account-inlog-redi...b29mZG1lbnUuaHRtbA==

Please try to log on with the following credentials to see what I mean:

This message contains confidential information


What you then see is an empty page (see point 1 attached) while you should see all the vendor control panel (point 2 in attachment)

Thanks in advance.
regards,
Joyce

Attachments:
Last edit: 1 year 2 days ago by joycehoveling.

Please Log in or Create an account to join the conversation.

  • Posts: 103
  • Thank you received: 0
  • Hikamarket Multivendor Hikashop Business
1 year 2 days ago #300624

Hello again.

After some puzzling it seemed to be the ACL which was not set up correctly.
So it's fixed.

Thanks and regards,
Joyce

Please Log in or Create an account to join the conversation.

  • Posts: 23806
  • Thank you received: 3692
  • MODERATOR
1 year 2 days ago #300626

Hello,

Good to know that you found the ACL configuration issue.

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

Moderators: Obsidev
Time to create page: 0.067 seconds
Powered by Kunena Forum