Address & Shipping in Checkout Configuration Doesn’t Work in Backend

  • Posts: 33
  • Thank you received: 3
  • Hikashop Business
3 months 3 weeks ago #303265

-- url of the page with the problem -- : n/a
-- HikaShop version -- : 4.0.2
-- Joomla version -- : 3.9.2
-- PHP version -- : 5.6.37
-- Browser(s) name and version -- : All
-- Error-message(debug-mod must be tuned on) -- : none

I love this feature for the front end of HikaShop. I went to System > Configuration > Checkout tab > Address & Shipping and rearranged the fields/tokens the way my client needs them to display. And it works great on the front end of HikaShop for customers seeing their saved addresses when they check out.

Unfortunately, that is the only place it works. You are not pulling the address format from that setting anywhere on the backend of HikaShop so email confirmations, invoices, and shipping invoices all display the information in the default order which is wrong for my client. So despite this handy feature, I still have to have a custom override here: administrator/templates/isis/html/com_hikashop/order/address_template.php

Please make update HikaShop so that this feature works everywhere an address is required.

Here is a video of the issue if it helps: www.useloom.com/share/74d8634c4cf042c081fb02e4d8a0e63b

Please Log in or Create an account to join the conversation.

  • Posts: 65715
  • Thank you received: 9593
  • MODERATOR
3 months 3 weeks ago #303279

Hi,

This setting works for both the frontend AND the backend.
I've just tested it again on my test website just to make sure and it is still working. So there is no bug here.
If it only does it for the frontend on your website, it means that the permissions on the file administrator/templates/isis/html/com_hikashop/order/address_template.php doesn't allow the user of your web server to write in that file. That would happen if for example you have another user for your FTP server and when you uploaded once that file via FTP it set the permissions to 644 (so other users can't write in it) and set the owner as the user of the FTP server.
So you need to make sure that the permissions on that file are correct and it should then work.

Please Log in or Create an account to join the conversation.

  • Posts: 33
  • Thank you received: 3
  • Hikashop Business
3 months 3 weeks ago #303306

Ah… Nicolas, you are my hero! I didn’t know how to handle what you said about a different user so I just deleted that address_template.php and resaved the Address & Shipping customization in HikaShop’s configuration. It created a new file using the correct info and now it works! Thank you, thank you!

Please Log in or Create an account to join the conversation.

Time to create page: 0.055 seconds
Powered by Kunena Forum