Social Network Plugin Enabled but nothing appears

  • Posts: 41
  • Thank you received: 0
9 years 1 month ago #186071

-- url of the page with the problem -- : www.bityard.com
-- HikaShop version -- : 2.3.5
-- Joomla version -- : 3.3.6

I enabled the Social Network plugin in Hikashop and saved the settings as per the link
www.hikashop.com/support/documentation/8...social-networks.html

However, when I go to the individual products, I do not see any social network icons. Could you tell me what I am missing?

Thank you in advance

Please Log in or Create an account to join the conversation.

  • Posts: 81118
  • Thank you received: 12980
  • MODERATOR
9 years 1 month ago #186093

Hi,

I see that your template has customized the display of the product page. So maybe it comes from that.
Try to switch to the default template of Joomla and see if that helps. If yes, then it indeed comes from the template which probably removed the {hikashop_social} from the product page layout.
In that case, edit the file "show" of the view "product" for your frontend template via the menu Display>Views and add {hikashop_social} tag there and see if that helps.
Otherwise, I would recommend to contact your template provider for help.

Please Log in or Create an account to join the conversation.

  • Posts: 41
  • Thank you received: 0
9 years 1 month ago #186187

I set the template to the default 'protostar'. Unfortunately, the social networking plugin still doesn't appear to be working.



When I go to System --> Plugins (pulldown menu listing), the social network plugin isn't there. So I click on "new" and on the list, the social network plugin isn't on the list.





BUT, then I go to System --> Plugins (horizontal menu tab listing), there is indeed a Social Network plugin, which is enabled.





So, I am not sure what am I doing wrong.

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 25971
  • Thank you received: 3998
  • MODERATOR
9 years 1 month ago #186190

Hi,

I set the template to the default 'protostar'. Unfortunately, the social networking plugin still doesn't appear to be working.

I can't say the same regarding your first screenshot, the social buttons are there, just above the product image.

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

  • Posts: 41
  • Thank you received: 0
9 years 1 month ago #186314

Wonderful! The code provided and pasted onto the file you pointed out in the Joomshaper/Organic Life template fixed the social network buttons. Now the social network icons show correctly.

Thank you very much!

Please Log in or Create an account to join the conversation.

  • Posts: 27
  • Thank you received: 1
1 year 3 weeks ago #348881

Hi everyone, I followed the post, but the strange thing is that the Facebook button doesn't appear, you can see it here: www.classicbikesregis.it/index.php/shop/...uct/183-olio-miscela -2t-nils-duosynt-for-mixer-tpi.html
i changed the tamplate from yootheme to cassiopea and i have the same result the problem remains.
the only doubt is what to write in Facebook admin, if I go to the link you recommend www.hyperarts.com/blog/how-to-create-fac...to-get-an-app-id-for -your-website/ I can't find the instructions!!!
i can't se Please can you help me?!
Thank you

Attachments:
Last edit: 1 year 3 weeks ago by aanconetani@libero.it. Reason: This is my configuration for the plugin, I can't see Google and AddThis display either

Please Log in or Create an account to join the conversation.

  • Posts: 81118
  • Thank you received: 12980
  • MODERATOR
1 year 3 weeks ago #348882

Hi,

Indeed, that link is dead.
Here is another page explaining the same thing:
webkul.com/blog/how-to-generate-facebook-app-id/

Please Log in or Create an account to join the conversation.

  • Posts: 27
  • Thank you received: 1
1 year 1 week ago #349358

I'm really sorry to disturb you, but I just can't get the social plugin for facebook to work!!
I created a facebook app as you indicated with the new link, I entered the ID but the facebook button does not appear.
I can't figure out the alternative Facebook admin: The ID of your Facebook account or your Product page, you can find this ID in the URL bar of your profile.
I have to put the full URL of my page?
Can you help me solve?
Thank you

Attachments:
Last edit: 1 year 1 week ago by aanconetani@libero.it. Reason: idea!!!! it might depend on the fb like DIV, it seems to me that it has a weird size!!!

Please Log in or Create an account to join the conversation.

  • Posts: 81118
  • Thank you received: 12980
  • MODERATOR
1 year 1 week ago #349359

Hi,

So I looked deeper into it.
If I check your product page, I can indeed see you set the app id and the plugin added the fb:admins meta tag to the page.
However, if I check your page with Facebook's debug tool I see this:
developers.facebook.com/tools/debug/?q=h...t%2F183-olio-miscela
It says fb:admins is missing.
So I looked into the difference between fb:admins and db:app_id and found this page:
developers.facebook.com/docs/plugins/com...n-setup-instructions
It basically says that either can be used and that for fb:admins you need to add your user ID not an app_id. So that's my bad.
Since the plugin uses fb:admins you need to get your facebook user id.
Here is a page explaining how to get it:
www.facebook.com/help/1397933243846983

Please Log in or Create an account to join the conversation.

  • Posts: 27
  • Thank you received: 1
1 year 6 days ago #349411

HI! Thanks for the reply!!!
I created the APP, I followed the instructions, but in my APP area ( www.facebook.com/settings?tab=applications&ref=settings ) I can't find any from which to take the fb:admins
Maybe I did something wrong?
in my developer (always the same FB account) I have many APPs including ClassiBikes, but I don't see them on my profile!
Is there a faster method to add a product share in FB?
example add a button in the product view? or something like that!!!
Thanks again!!!!!

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 27
  • Thank you received: 1
1 year 6 days ago #349415

Small update, now my ClassicBikes App has appeared in the Apps and websites of my profile, I clicked view and edit and it offers me my user ID
copy paste it in the social plugin, if now I analyze the Debuger page as Nicolas taught me I get this:
Missing Properties The following required properties are missing: fb:app_id

Something has changed but the Facebook button is not visible.
the weird thing is i don't see google+ and addthis either

Please help me!!
An alternative solution is fine too!!!

Please Log in or Create an account to join the conversation.

  • Posts: 81118
  • Thank you received: 12980
  • MODERATOR
1 year 5 days ago #349412

Hi,

You need to find the user id in your facebook profile:

Click your profile picture in the top right of Facebook.
Select Settings & privacy, then click Settings.
Click Security and login in the left menu.
Click Apps and Websites in the left menu.
Click View and edit next to an app or game.
Scroll down to LEARN MORE. Your user ID is in the paragraph below.

The set this user id in the settings of the plugin.

The following user(s) said Thank You: aanconetani@libero.it

Please Log in or Create an account to join the conversation.

  • Posts: 27
  • Thank you received: 1
1 year 5 days ago #349432

Hi Nicolas,
that's exactly what I did, but after putting the user ID, it still didn't work.
I think I fixed it by putting the Social Plugin as last in the Joomla oredring, now it works!
Thanks for collaboration

The following user(s) said Thank You: nicolas

Please Log in or Create an account to join the conversation.

Time to create page: 0.106 seconds
Powered by Kunena Forum