Version upgrade query

  • Posts: 34
  • Thank you received: 1
  • Hikashop Business
4 months 2 weeks ago #303537

-- Joomla version -- : 3.8.10
-- PHP version -- : 7.0.33
-- Browser(s) name and version -- : Firefox

Hi,

I have just taken over a website with Hikashop installed. It's on an old version number, but it doesn't say what version of Hikashop it's using, ie starter, essential or business...

I have attached a screenshot so that you might be able to help me tell.

It's obviously a big update, 2.4.0 - 4.0.1 - is there anything I should know about making such a big jump. I'm thinking I should do it on a test site first.

Regards

Duncan


DunxMax

The more we learn the less we know.
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 66041
  • Thank you received: 9666
  • MODERATOR
4 months 2 weeks ago #303539

Hi,

Yes, it's a big update so it's indeed a good idea to do it first on a test website.
Note that from 2.X to 3.x, we've reworked the add to cart and checkout systems.
So it's possible that you have issues after the update regarding these, especially with customization in place.
We do have settings under the "advanced" tab of the HikaShop configuration to activate/deactivate the legacy mode of the add to cart and checkout systems among other things. So if you have issues with them after the update, it's a good thing to first try switching these settings.
Aslo, if the CSS was customized, you might get that issue as we changed the grid system with HikaShop 3:
www.hikashop.com/forum/install-update/88...r-update.html#260059
That's the most common issues after such updates and with the solutions provided above, it should be easy to fix.

Please Log in or Create an account to join the conversation.

  • Posts: 34
  • Thank you received: 1
  • Hikashop Business
4 months 2 weeks ago #303559

Thanks Nicolas for your reply.

Looks like I've got some work on my hands.

Did you take a look at my screenshot, which version of hikashop is my system using. ie starter, essential or business?


DunxMax

The more we learn the less we know.

Please Log in or Create an account to join the conversation.

  • Posts: 66041
  • Thank you received: 9666
  • MODERATOR
4 months 2 weeks ago #303564

Hi,

Turn on temporarily the "show footer" setting of the HikaShop configuration and you'll see the edition name at the bottom of each page displayed by HikaShop.
Note that with HikaShop 3.x and forward, the first setting of the HikaShop configuration is actually the edition and version of HikaShop you have so once you update, you'll be able to easily know which version you have at any time.

Please Log in or Create an account to join the conversation.

  • Posts: 34
  • Thank you received: 1
  • Hikashop Business
4 months 5 days ago #303941

Hi Nicolas,

I haven't done my upgrade yet, mainly because I need to plan in the time, but in the meantime the customer has asked me to do some work on VAT settings.

They would like to set VAT setting for the whole of the EU. Currently they have a VAT setting for individual countries within the EU, which all need to now be set to 20%, so the question is do I need to change them all individually or can I set one VAT zone of 20% for countries in the EU?

Thanks for any help you can provide on this.

The version of Hikashop is 2.4.0

Regards

Duncan


DunxMax

The more we learn the less we know.

Please Log in or Create an account to join the conversation.

  • Posts: 66041
  • Thank you received: 9666
  • MODERATOR
4 months 5 days ago #303946

Hi,

You can create one tax rule for each country via the menu System>Taxes, each time, you can specify the tax category, the tax rate and the zone corresponding. You'll have to first create the tax rates via the button "manage tax rates" of the System>Taxes menu.
If several countries share the same tax rate, you could potentially group them into one tax rule, but I don't think that your version of HikaShop supports the possibility to select several zones in the zone restriction setting of the tax rules. So you would have to first create a tax zone with the different countries as sub zones in the System>Zones menu ( or have one tax rule per zone ).

Please Log in or Create an account to join the conversation.

  • Posts: 34
  • Thank you received: 1
  • Hikashop Business
3 months 1 week ago #304685

Hi,

It's been a while since I started this thread, but I've now started the update process on my testing site. All went very well apart from I've lost the category listings. You said there might be an issue and it's probably the problem with the grid system that you mentioned earlier in this thread.

I followed your link and it says to delete some css code on line 42 of the Hikashop frontend CSS. What's not clear is which file this refers to in my views. And the question is will this solve the problem?

Here's a link to a shop category on my updated test site: ukm10.siteground.biz/~conforma/shop-test...8/category/machinery

And here's a link to the same page on the live site, which still uses the old version of Hikashop: shop.conformance.co.uk/hikashop-menu-for...8/category/machinery

If you can you help steer me in the right direction - I would be most grateful.

Regards

Duncan


DunxMax

The more we learn the less we know.

Please Log in or Create an account to join the conversation.

  • Posts: 66041
  • Thank you received: 9666
  • MODERATOR
3 months 1 week ago #304686

Hi,

Check if you have the file templates/YOUR_TEMPLATE/html/com_hikashop/category/listing.php
If you do, rename it in order to deactivate that view override and it should fix the problem.

Please Log in or Create an account to join the conversation.

  • Posts: 34
  • Thank you received: 1
  • Hikashop Business
3 months 1 week ago #304721

Hi Nicolas,

Thanks for your reply - I appreciate the help you are giving me on this.

I don't have that file in my html. I have added a screenshot of the com_hikashop directory so you can see what's there. There is no category folder.

Regards

Duncan


DunxMax

The more we learn the less we know.
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 66041
  • Thank you received: 9666
  • MODERATOR
3 months 1 week ago #304722

Hi,

Then I'm not sure what is the problem.
Please check the settings of the menu item with the alias "hikashop-menu-for-module-98" via the menu manager of Joomla.
Please provide screenshots of the settings under the products options tab.

Please Log in or Create an account to join the conversation.

  • Posts: 34
  • Thank you received: 1
  • Hikashop Business
3 months 6 days ago #304846

Hi Nicolas,

Screenshot of menu item/product options attached.

Thanks

Duncan


DunxMax

The more we learn the less we know.
Attachments:
Last edit: 3 months 6 days ago by dunxmax.

Please Log in or Create an account to join the conversation.

  • Posts: 66041
  • Thank you received: 9666
  • MODERATOR
3 months 6 days ago #304851

Hi,

The settings look good and it's not an override, so I don't know what it could be.
Please provide a backend access, a FTP access and a link to this thread via our contact form so that we can have a look at the situation directly on your website.
www.hikashop.com/support/contact-us.html

Please Log in or Create an account to join the conversation.

  • Posts: 34
  • Thank you received: 1
  • Hikashop Business
3 months 2 days ago #305005

Hi Nicolas,

Just picked this up - I will fill out the contact form.

Thanks for your help.

Duncan


DunxMax

The more we learn the less we know.

Please Log in or Create an account to join the conversation.

  • Posts: 66041
  • Thank you received: 9666
  • MODERATOR
3 months 2 days ago #305012

Hi,

I think I've found the problem.
I was unable to verify the patch on your website as the FTP access you provided didn't work however.
I've added the patch on our end. Download the install package of HikaShop on our website via the menu My account>My subscriptions and install it again on your test website and that will add the patch I've added, which should hopefully fix the problem.
If that's confirmed, you can just do the normal update on your website and you won't have the problem as you'll have the patch too.

Please Log in or Create an account to join the conversation.

  • Posts: 34
  • Thank you received: 1
  • Hikashop Business
3 months 2 days ago #305014

Yes that's worked.

Thanks very much.

Regards

Duncan


DunxMax

The more we learn the less we know.

Please Log in or Create an account to join the conversation.

  • Posts: 34
  • Thank you received: 1
  • Hikashop Business
2 months 3 weeks ago #305291

Hi Nicolas,

I was just doing final testing before I apply the update to my live site, but discovered an issue, and just need a bit of advice on how to solve. I'm sure it's not too big a problem.

On each page I have a cart module.

I can see that when I add a product to the cart I get an small box that flashes up to say the product is added to the cart, but what's not happening at the same time is that my cart module is not being updated. The module only updates when I refresh the browser, ie it's not doing updating automatically.

I tested the live site with the old version of Hikashop and the module does update automatically.

Is there a setting somewhere I need to change to make sure the cart is updated when a product is added.

Test site is here: ukm10.siteground.biz/~conforma/shop-test/

As always very grateful for any help.

Regards

D


DunxMax

The more we learn the less we know.

Please Log in or Create an account to join the conversation.

  • Posts: 66041
  • Thank you received: 9666
  • MODERATOR
2 months 3 weeks ago #305303

Hi,

You're missing the javascript code of the cart module which handles the refresh of itself. I suppose that you have a view override of the cart module from an old version of HikaShop.
Check if you have the file templates/YOUR_TEMPLATE/html/com_hikashop/product/cart.php via FTP and if you do, rename it. It should then work properly. You can always redo the view override on the new version of that view file via the menu Display>Views in order to add your customizations to the cart module.

Please Log in or Create an account to join the conversation.

  • Posts: 34
  • Thank you received: 1
  • Hikashop Business
2 months 2 weeks ago #305616

Hi Nicolas,

Finally got round to looking at this. You are right. I renamed the cart.php and the cart now updates.

Thanks very much.

D


DunxMax

The more we learn the less we know.

Please Log in or Create an account to join the conversation.

  • Posts: 34
  • Thank you received: 1
  • Hikashop Business
1 month 4 weeks ago #306062

Hi Nicolas,

I have now upgraded hikashop on the live version of the site. A problem has been spotted.

The problem is with emails.

The order number is not appearing in the places where it should appear. This was working before the upgrade.

I took a look in the languages and found the various lines, which set the email content.

For example for "subject" it looks like this: ORDER_STATUS_NOTIFICATION_SUBJECT="Your order No. %s is now %s at %s"

I'm not sure how %s is determined, but the %s for order number is not being returned.

I am sending a screenshot to show you the resulting email.

Any help always appreciated.

Thanks

Duncan
PS apologies if you have more than one screenshot, I tried to send an edited version of the screenshot and delete the first one, but the "remove file " functionality for attachments doesn't work very well.


DunxMax

The more we learn the less we know.
Attachments:
Last edit: 1 month 4 weeks ago by dunxmax.

Please Log in or Create an account to join the conversation.

  • Posts: 66041
  • Thank you received: 9666
  • MODERATOR
1 month 3 weeks ago #306104

Hi,

The %s in the translation

ORDER_STATUS_CHANGED_TO="The status of your order No. %s has been changed to %s."

of your screenshot is generated in the preload of the order status notification email. You can see it in the menu System>Emails at the bottom when you edit that email:
monosnap.com/file/4c4aNxcF2O0R8ZpSxHr1xU6s1ubnhf
However, I don't see how the order number would be missing there and all the rest of the information present. At least not with the code of the preload of recent versions of HikaShop. So either you have modified the preload in some weird way or you have a really old preload override (you can check whether you have an override or not on the listing of the emails) which has a bug preventing it from displaying the order number properly.

Please Log in or Create an account to join the conversation.

Time to create page: 0.088 seconds
Powered by Kunena Forum