Help with Payment Status Auto Update

  • Posts: 12
  • Thank you received: 1
  • Hikashop Business
9 months 1 week ago #298741

Hi,

I have tested by changing that ? to a ; and it's still not working :(

What are my options from here ?

Please Log in or Create an account to join the conversation.

  • Posts: 2188
  • Thank you received: 292
  • MODERATOR
9 months 1 week ago #298753

Hello,

I can't tell you better than previously said, we need more clue to understand why in your specific case something don't work, Account Settings ? Your website Server ? etc...

This plugin was used to work for other people, now we have to process some test with your Payway account.
Have a look on your settings can maybe learn us news point to improve.

If for a reason or another you don't want let us have a look on this, I can invite you to create a new test account but you have to reproduce each settings, to be sure to work in the same context.

Note : You can use a Contact us form, to provide these kind of references, don't forget to add an Url link to this topic.

Awaiting news from you.
Regards

Last edit: 9 months 1 week ago by Philip.

Please Log in or Create an account to join the conversation.

  • Posts: 11
  • Thank you received: 0
9 months 1 week ago #298900

We're having this very same issue

Please Log in or Create an account to join the conversation.

  • Posts: 2188
  • Thank you received: 292
  • MODERATOR
9 months 6 days ago #298909

Hello,

Ok and maybe you can help us to move forward in this subject ? Can you let us process some test on your account OR a test account with the same settings ?

Regards

Last edit: 9 months 1 week ago by Philip.

Please Log in or Create an account to join the conversation.

  • Posts: 11
  • Thank you received: 0
8 months 3 weeks ago #299519

Yes I can, would you like me to create a user for you for our dev site?

Please Log in or Create an account to join the conversation.

  • Posts: 2188
  • Thank you received: 292
  • MODERATOR
8 months 3 weeks ago #299529

Hello,

Yes please, reproduce exactly your configuration, and provide us your account references and backend access for your website (clone or offline website).
You can use your Contact us form to provide this references and don't forget to add to your message an Url link to this topic.

Regards

Last edit: 8 months 3 weeks ago by Philip.

Please Log in or Create an account to join the conversation.

  • Posts: 11
  • Thank you received: 0
8 months 3 weeks ago #299661

I've turned Error Reporting to Maximum and now see the following error

Notice: Undefined index: SERVER_ADDR in D:\sites\horseandhound\horseandhound.com.au\home\plugins\hikashoppayment\westpacnet\westpacnet.php on line 34

Please Log in or Create an account to join the conversation.

  • Posts: 2188
  • Thank you received: 292
  • MODERATOR
8 months 3 weeks ago #299668

Hello,

As said previously, unfortunately we won't be able to help you without backend access and account references in order to process ourself tests.

Can't say more from this, except maybe about your notice error, this may not explain the payment issue.
Regards

Please Log in or Create an account to join the conversation.

  • Posts: 11
  • Thank you received: 0
8 months 2 weeks ago #299761

Hi

I've just sent you a message through your contact form with particulars so you can process your tests.

Please Log in or Create an account to join the conversation.

  • Posts: 2188
  • Thank you received: 292
  • MODERATOR
8 months 2 weeks ago #299781

Hello,

I process some tests and so far I can just confirm that this issue seems to be the same, or at least have the same effects.

Now, in order to have a complete view of the situation, can you provide :
- Your Westpac merchant account references
OR
- Create a merchant test account that exactly reproduce your Merchant Configuration and provide these references.

The point is to understand how did you configure your Merchant Account and to see if we have something to improve on our side.
Awaiting news from you.

regards

Last edit: 8 months 2 weeks ago by Philip.

Please Log in or Create an account to join the conversation.

  • Posts: 11
  • Thank you received: 0
8 months 1 week ago #300195

Can you be more specific as to what settings you need? The merchant account has been configured as instructed.

Please Log in or Create an account to join the conversation.

  • Posts: 23550
  • Thank you received: 3654
  • MODERATOR
8 months 1 week ago #300208

Hello,

Philippe needs an access to the Westpac administration website in order to have the details of your configuration regarding the various settings (in Westpac) and the "IPN" (notification url).
For what I understand, you provided a backend access to your joomla website ; which do not allow to check and see the settings in Westpac website.

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

  • Posts: 11
  • Thank you received: 0
8 months 6 days ago #300380

It's not possible to provide you access to the actual Westpac account, for security this obviously isn't allowed. Here are some settings I assume you need.

Notification URL
/index.php?option=com_hikashop&ctrl=checkout&task=notify¬if_payment=westpacnet&tmpl=component;payment_reference&payment_status


Broswer Return URL
/index.php?option=com_hikashop&ctrl=checkout&task=notify¬if_payment=westpacnet&tmpl=component;payment_reference&payment_status

Is there other settings you would need?

Last edit: 8 months 6 days ago by philw.

Please Log in or Create an account to join the conversation.

  • Posts: 2188
  • Thank you received: 292
  • MODERATOR
8 months 5 days ago #300383

hello,

I understand your point, and that's why I invite you to create another Westpac administration website (a test account) WITH the exact same configuration settings.

You have to know that for us, Westpac was used to work and so if in your case (like previous user) that don't work that can be a lot of different reason (including our reason), but for understand we need a complete view of the situation.

regards

Last edit: 8 months 6 days ago by Philip.

Please Log in or Create an account to join the conversation.

  • Posts: 11
  • Thank you received: 0
8 months 4 days ago #300491

Ok, have setup a test account. Will send details through contact form.

Please Log in or Create an account to join the conversation.

  • Posts: 2188
  • Thank you received: 292
  • MODERATOR
8 months 3 days ago #300507

Hello,

The test account you create didn't work, I have this message error :



this means that among your references on your website test something isn't well setted.
So I try to find in the documentation to get the right references but I will be honest the Payway documentation is really difficult to follow.

So can you please, set up with good references the test account in order to have a good start for us to process tests.
I think you can understand that our time is more precious to understand root issue.

Sorry for this return.
regards

Please Log in or Create an account to join the conversation.

  • Posts: 11
  • Thank you received: 0
8 months 3 days ago #300539

Please try again. The username for the live site and test site were around the wrong way. The test site now has the correct username and password.

Please Log in or Create an account to join the conversation.

  • Posts: 2188
  • Thank you received: 292
  • MODERATOR
8 months 2 days ago #300555

Hello,

I'm sorry but did you test yourself, for me I' m always at the same step, with the same (or close screen)...
Did you check as well your Encryption Key and maybe the billercode ?

Awaiting news from you to progress.
regards

Last edit: 8 months 3 days ago by Philip.

Please Log in or Create an account to join the conversation.

  • Posts: 11
  • Thank you received: 0
8 months 2 days ago #300594

I've just made a couple of modifications to the settings if you can try again. I don't seem to be able to find any reference to a biller code though for a test account.

Please Log in or Create an account to join the conversation.

  • Posts: 23550
  • Thank you received: 3654
  • MODERATOR
8 months 2 days ago #300623

Hello,

Philippe is currently out of the office and will come back Tuesday.
Since he is familiar with Westpac, it will be better to wait for his return.

Thank you for your patience.


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

Time to create page: 0.106 seconds
Powered by Kunena Forum