Double timezone specification

  • Posts: 72
  • Thank you received: 2
  • Hikashop Business
1 year 8 months ago #270267

-- HikaShop version -- : 3.0.1
-- Joomla version -- : 3.7.2
-- PHP version -- : 5.6.30
-- Browser(s) name and version -- : Chrome last version
-- Error-message(debug-mod must be tuned on) -- : 0 DateTime::__construct(): Failed to parse time string (-001-11-29T23:40:28+00:00) at position 7 (-): Double timezone specification

Hi !


After update to the latest J! version today, wanting to edit my report, i get the following error :

0 DateTime::__construct(): Failed to parse time string (-001-11-29T23:40:28+00:00) at position 7 (-): Double timezone specification

In my search in the forum, I could only find this topic that is related :
Forum search result

But this seems to old to be of help.

Any help will be grately appreciated !

Thanks !

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 64866
  • Thank you received: 9396
  • MODERATOR
1 year 8 months ago #270268

Hi,

I don't know why you have that but the first dash shouldn't be there in the date.
Change the line:
return JHTML::_('date',$time,$format,false);
to:
return JHTML::_('date',ltrim($time,'-'),$format,false);
in the file administrator/components/com_hikashop/helpers/helper.php and that should prevent that issue from happening.
Please report back on the result.

The following user(s) said Thank You: ijsbaanleuven

Please Log in or Create an account to join the conversation.

  • Posts: 72
  • Thank you received: 2
  • Hikashop Business
1 year 8 months ago #270269

Hi Nicolas !

Thanks for the super fast replay (as usual) :-)

Seems to work, but, in the "Display" box, in the field of the end date, I now get the following : 3940-02-03 01:19.
When I clear the filed and hit save, it just returns.

When I go to the calendar symbol to pick an end date, it starts in the year 2100 :-) :-)

When I choose the correct date and save the file it works just fine and stays correct.

BR,

Joris

Please Log in or Create an account to join the conversation.

  • Posts: 64866
  • Thank you received: 9396
  • MODERATOR
1 year 8 months ago #270271

Hi,

We'll look at doing a better patch then.
I'm glad the problem is now solved for you.

Please Log in or Create an account to join the conversation.

Time to create page: 0.054 seconds
Powered by Kunena Forum