orders shifted one or two months back in report

  • Posts: 3
  • Thank you received: 0
1 week 15 hours ago #312857

-- HikaShop version -- : 4.2.2
-- Joomla version -- : 3.9.12
-- PHP version -- : 7.1

I have a report with start date 2019-07-18 and end date 2020-04-22
the graph x-axis labels start with 2019-05-22 (not 2019-07-18)
the next label is not on 6-22 but on 6-1
then it continues on first of the month until month 11. it ends with 2020-03-22

the graph then shows no orders for 2019-11-22 and only one order for 2019-10-1
there were more orders. but it somehow bundles those in month 9.

other reports settings:
- date type : created
- group by month
- type : orders with filter : status = shipped
(see screenshot 21 and 22)

when I change the settings to start date 2019-01-01 and end date 2019-12-31 the report sstarts 2 months earlier and ends one month early. and it lacks month 10 all together.
(screenshot 23 and 24)

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 67389
  • Thank you received: 9992
  • MODERATOR
6 days 10 hours ago #312910

Hi,

It's hard to say much besides that I don't have the issue on my end. Could you provide screenshots of the whole page with all the settings and the whole graph ?

Please Log in or Create an account to join the conversation.

  • Posts: 3
  • Thank you received: 0
5 days 18 hours ago #312926

Hi Nicolas,



as you can see start date is 1/15 in settings while it starts 11/16
then it starts display periods every first of the month up to this month and it stops a month early.

regards,
John

Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 0.089 seconds
Powered by Kunena Forum