orders shifted one or two months back in report

  • Posts: 10
  • Thank you received: 0
1 year 3 weeks ago #312857

-- HikaShop version -- : 4.2.2
-- Joomla version -- : 3.9.12
-- PHP version -- : 7.1

I have a report with start date 2019-07-18 and end date 2020-04-22
the graph x-axis labels start with 2019-05-22 (not 2019-07-18)
the next label is not on 6-22 but on 6-1
then it continues on first of the month until month 11. it ends with 2020-03-22

the graph then shows no orders for 2019-11-22 and only one order for 2019-10-1
there were more orders. but it somehow bundles those in month 9.

other reports settings:
- date type : created
- group by month
- type : orders with filter : status = shipped
(see screenshot 21 and 22)

when I change the settings to start date 2019-01-01 and end date 2019-12-31 the report sstarts 2 months earlier and ends one month early. and it lacks month 10 all together.
(screenshot 23 and 24)

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 71219
  • Thank you received: 10726
  • MODERATOR
1 year 3 weeks ago #312910

Hi,

It's hard to say much besides that I don't have the issue on my end. Could you provide screenshots of the whole page with all the settings and the whole graph ?

Please Log in or Create an account to join the conversation.

  • Posts: 10
  • Thank you received: 0
1 year 3 weeks ago #312926

Hi Nicolas,



as you can see start date is 1/15 in settings while it starts 11/16
then it starts display periods every first of the month up to this month and it stops a month early.

regards,
John

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 10
  • Thank you received: 0
1 year 2 weeks ago #313087

Any troubleshooting steps or advice?

Please Log in or Create an account to join the conversation.

  • Posts: 12631
  • Thank you received: 1736
  • MODERATOR
10 months 2 weeks ago #314681

Hello and sorry for the late reply,

Sure ! we finally succeed to reproduce and fix that issue on our end, can you download the last HikaShop version through our website, install it and test it again ? Thank you.

Kind regards,
Mohamed.

Please Log in or Create an account to join the conversation.

  • Posts: 189
  • Thank you received: 7
  • Hikashop Business
2 months 2 weeks ago #323941

Hi jivjivjiv,,

Did this fix indeed solve your problem?
And in which version of Hikashop was the fix included? Hikashp 3.2.3??

I have a problem reminiscent to yours: in my webshop the monthly report starts 1 month too early
Start date is 01-01-2020, but the x- axis shows Dec, 01. (See my topic Wrong dates statistisc by month )
I'm using Hikshop 4.3.0

Thanks,
Udo

Please Log in or Create an account to join the conversation.

  • Posts: 12631
  • Thank you received: 1736
  • MODERATOR
2 months 2 weeks ago #323975

Hello Udo,

It actually fixed the issue when I tested it on my end and also on our client's website.

Also I can't reproduce it on my end when I test it.

Kind regards,
Mohamed.

Please Log in or Create an account to join the conversation.

Time to create page: 0.110 seconds
Powered by Kunena Forum