Vote System Updates Stars But Not Comments

  • Posts: 76
  • Thank you received: 2
10 years 6 months ago #119186

Hi there,

Since updating Hikashop my vote system seems to have crashed:
- The system is set up with connected stars and comments.
- When a review is left, the stars update, but the comment is lost.
- In the back end under customers->vote I see an empty screen and pressing the "new" button does nothing.
- I did have some view overrides for vote, but have got rid of them and the problem still persists for all my site's products.

Here are some details:

-- Site: www.claycellar.org
-- HikaShop version -- : Business 2.2.0
-- Joomla version -- : 2.5.0
-- PHP version -- : 5.3.10
-- Browser(s) name and version -- : Firefox 21.0 on Ubuntu Canonical

If you require login access/ftp access I can message these to you privately.

Any advice would be much appriciated! Many thanks,

Jonathan

Please Log in or Create an account to join the conversation.

  • Posts: 13201
  • Thank you received: 2322
10 years 6 months ago #119483

Hi,

I am not able to reproduce that bug in backend, and I don't see any error on the browser console when sending a vote on your website.
Thanks to give us a backend access, and a ftp one in order to see from where can the problem come.

Please Log in or Create an account to join the conversation.

  • Posts: 115
  • Thank you received: 8
10 years 6 months ago #119492

When you click on the star - page updated and printed text commentary cleared :-(

ibaby.com.ua/buy/price/3566-японские-подгузники-merries-nb
1) Write the text of your comment
2) Сlick on the star rating

It can be either text comment or rating...


my project ibaby.com.ua
Last edit: 10 years 6 months ago by zlenko.

Please Log in or Create an account to join the conversation.

  • Posts: 13201
  • Thank you received: 2322
10 years 6 months ago #119495

Hi,

Actually when a vote is submitted the page is reloaded, so it's normal that the forms are cleared.
You don't set the configuration to "vote and comment connected" that's why you can send a vote OR a comment.

We have in the todo list to improve the vote and comment system.

The following user(s) said Thank You: zlenko

Please Log in or Create an account to join the conversation.

  • Posts: 115
  • Thank you received: 8
10 years 6 months ago #119496

Thank you. I'll try to set the "vote and comment connected".


my project ibaby.com.ua

Please Log in or Create an account to join the conversation.

  • Posts: 76
  • Thank you received: 2
10 years 6 months ago #119531

Hi Xavier,

I've sent you a private message with backend and ftp access. Can you confirm receipt please?

The problem itself can be experienced by going to: www.claycellar.org/index.php/clay/earthe...r-setting-clay-white

Leaving a vote and comment, clicking submit, waiting for the page to reload, then noting that the comment isn't added to the page whilst the vote is.

Many thanks,

Jonathan

Please Log in or Create an account to join the conversation.

  • Posts: 13201
  • Thank you received: 2322
10 years 6 months ago #119537

I received the access.

Can you specify which files you had edited ?
And can you try to install again the latest version of HikaShop (download from our website) ?

Please Log in or Create an account to join the conversation.

  • Posts: 76
  • Thank you received: 2
10 years 6 months ago #119555

I had edited all three of the vote views, but I have got rid of the edits in the back end and the system still doesn't work.

I can do that, but I've not anything that would affect the vote system to my knowledge since last updating hikashop. I will give it a go all the same...

Jonathan

Please Log in or Create an account to join the conversation.

  • Posts: 76
  • Thank you received: 2
10 years 6 months ago #119571

Ok,

So somehow I had edits to some of the backend bluestork view files for vote. I never thought to look at this because I never touch backend views out of policy. I'm not so sure how they got there, but presumably I must have caused it at some point.

Anyway getting rid of the backend view changes, and going through the MYSQL tables eradicating all trace of votes all ready made, fixed the system. It's working fine now.

Thanks for your help.

Jonathan

Please Log in or Create an account to join the conversation.

Time to create page: 0.089 seconds
Powered by Kunena Forum