Product custom field values not saving in backend of product

  • Posts: 11
  • Thank you received: 0
  • Hikashop Business
6 months 4 weeks ago #314698

-- HikaShop version -- : 4.2.2
-- Joomla version -- : 3.9.13
-- PHP version -- : 7.2.22
-- Browser(s) name and version -- : firefox mac
-- Error-message(debug-mod must be tuned on) -- : No error message present on the page

Hello,

I have a multi-select custom field added to a product. When I navigate to the back-end of the product, make a selection or two from the multi-select and save, some values save and some do not.

An example: Multi-select custom field name "Mounting" with the following structure.

Mounting
- Horizontal Mounting
- Vertical Mounting
- 1" Pipe Mounting
- 1-1/4" Pipe Mounting

If I select Horizontal Mounting or Vertical Mounting or both, the values save into the product. If I select 1" Pipe Mounting or 1-1/4" Pipe Mounting the values do not save. It seems like the double quote in the value is causing an issue. Perhaps the custom field values need to html entity encoded before they're placed into the option value="" in the DOM.

Please Log in or Create an account to join the conversation.

  • Posts: 2648
  • Thank you received: 348
  • MODERATOR
6 months 3 weeks ago #314703

Hello,

Can you provide theses elements in order to better understand the context ?
we need :
- A screenshot of your relative custom field setting page
- Any relatives elements that will help us to reproduce your configuration on our side

Awaiting news to progress on your subject.
Regards

Last edit: 6 months 3 weeks ago by Philip.

Please Log in or Create an account to join the conversation.

  • Posts: 11
  • Thank you received: 0
  • Hikashop Business
6 months 3 weeks ago #314720

screenshots attached

Attachments:
Last edit: 6 months 3 weeks ago by elevology. Reason: wrong screenshots added

Please Log in or Create an account to join the conversation.

  • Posts: 2648
  • Thank you received: 348
  • MODERATOR
6 months 3 weeks ago #314721

Hello,

Thanks for your returns ! It able us to improve our code to manage specific cases like yours, here you have some " and start your value by a number, both of these leads to a bug.

You can now update to have the fix, and your solution.

Regards

Last edit: 6 months 3 weeks ago by Philip.

Please Log in or Create an account to join the conversation.

  • Posts: 11
  • Thank you received: 0
  • Hikashop Business
6 months 3 weeks ago #314768

Hello, I went into my subscriptions and downloaded hikashop but it's showing v4.2.2 which is the version I already had installed prior to reporting this bug. Does this download contain the bug fix I need even though you didn't increment the version number?

Please Log in or Create an account to join the conversation.

  • Posts: 70198
  • Thank you received: 10513
  • MODERATOR
6 months 3 weeks ago #314822

Hi,

Yes. We made a hot patch we've added to the current release so that you can get the fix easily. Since it's not a big problem we'll wait for the next release for everyone else to get the patch. Otherwise, if we were doing a new release each time we fix a small issue, we would do a release each day which would bother everyone for fixes they don't care about.

Please Log in or Create an account to join the conversation.

  • Posts: 11
  • Thank you received: 0
  • Hikashop Business
6 months 3 weeks ago #314942

Hello, I'm not sure how you patched this but I need to report some more bugs here. ® ® breaks it. I'd recommend some kind of unit test here, testing your function against a variety of characters.

Last edit: 6 months 3 weeks ago by elevology.

Please Log in or Create an account to join the conversation.

  • Posts: 11
  • Thank you received: 0
  • Hikashop Business
6 months 3 weeks ago #314945

The ampersand (&) symbol also breaks it.

Please Log in or Create an account to join the conversation.

  • Posts: 70198
  • Thank you received: 10513
  • MODERATOR
6 months 2 weeks ago #314974

Hi,

Thank you for your feedback. We've added another patch for that.

Please Log in or Create an account to join the conversation.

  • Posts: 11
  • Thank you received: 0
  • Hikashop Business
6 months 2 weeks ago #315040

™ ™ also breaks it

Last edit: 6 months 2 weeks ago by elevology.

Please Log in or Create an account to join the conversation.

  • Posts: 11
  • Thank you received: 0
  • Hikashop Business
6 months 2 weeks ago #315041

Also something in this string breaks it: CAT 4, 40 cal/cm2

Please Log in or Create an account to join the conversation.

  • Posts: 70198
  • Thank you received: 10513
  • MODERATOR
6 months 2 weeks ago #315042

Hi,

I'm not able to reproduce the issue with either of your two last examples thanks to the patch we've added 2 days ago here www.hikashop.com/forum/product-category-...-product.html#314974
So make sure you've downloaded the install package on our website and installed it on your website again to get the patch.

Please Log in or Create an account to join the conversation.

Time to create page: 0.071 seconds
Powered by Kunena Forum