Force Default Payment Method

  • Posts: 573
  • Thank you received: 24
  • Hikashop Essential
1 month 2 days ago #331645

-- url of the page with the problem -- : www.ariesgamesandminis.com
-- HikaShop version -- : 4.4.1
-- Joomla version -- : 3.9.25
-- Browser(s) name and version -- : Chrome

I have searched, and I have switched the plugin position of the Square payment method, but even after clearing the cache, logging out and back in to the site, my Square payment method will not show as the default for the site. It continues to show PayPal as the default and I cannot make it change.

Any suggestions?

Plugin Position



Checkout Position & Default Shown

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 72763
  • Thank you received: 11096
  • MODERATOR
4 weeks 1 day ago #331657

Hi,

The payment method will be taken into account. The first one in the list will be selected automatically.
Note however that the selected payment method is linked to the cart.
So once a payment method has been selected for a cart, even if you change the order of the payment methods, you won't see the other one being selected unless you delete your cart.
So to make sure that it works, just try on another browser with a new cart and a new user account and you'll have the correct pre selected one.

Please Log in or Create an account to join the conversation.

  • Posts: 573
  • Thank you received: 24
  • Hikashop Essential
4 weeks 1 day ago #331681

I just tried another browser, still shows PayPal as the default. So I cleared cache on the site and on the host, still shows PayPal as the default.

Please see the attached screen shots...have I done something wrong?





Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 72763
  • Thank you received: 11096
  • MODERATOR
4 weeks 17 hours ago #331688

Hi,

I checked the situation and that's normal.
That's because you've limited the Square payment method to a zone.
Because of that, the payment method is not available before the user has logged in and entered his address.
So the moment he adds a product in the cart, the available payment methods are loaded and the first one is selected. And since at that point only PayPal is available, it is selected as default.
To avoid that, what you can do is set the "access level" of both your payment methods to "registered". That way, before the user logs in, no payment method will be available and thus no payment method will be preselected. And then, after the user logs in with an address in the USA, both payment methods will be available and the first one will be selected.

Please Log in or Create an account to join the conversation.

  • Posts: 573
  • Thank you received: 24
  • Hikashop Essential
4 weeks 22 minutes ago #331725

That worked! Thank you very much sir!

Please Log in or Create an account to join the conversation.

  • Posts: 573
  • Thank you received: 24
  • Hikashop Essential
3 weeks 6 days ago #331726

Nicolas...slight issue, please see the attached screen shot. When activating the "registered" setting on the payment options, now I have errors on my dashboard. Please see the red highlighted errors as shown.

How can I resolve this?

Attachments:
Last edit: 3 weeks 6 days ago by Dragon41673.

Please Log in or Create an account to join the conversation.

  • Posts: 573
  • Thank you received: 24
  • Hikashop Essential
3 weeks 6 days ago #331727

Ok...ignore that. It seems to be a scripting error caused by some crash at Google from what I'm reading, and my sales chart (the top one) is already back online. Just bad timing that it went down when I changed those settings.

I do have a question. Please see the attached screen shot. Is this warning at the top a potential issue?

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 72763
  • Thank you received: 11096
  • MODERATOR
3 weeks 6 days ago #331732

Hi,

It seems that you set the "access" of the square and paypal plugins to "registered" instead of using the "access level" setting of the square and paypal payment methods as I had recommended.
If you do it with the access setting of the plugins, PayPal won't load the plugins when the payment notification is received and thus, your orders won't be confirmed automatically. And that's why you get that warning message.
So please revert that setting to "public".
Instead, you need to use the "access level" setting in the payment methods. Please note that this setting is only available with HikaShop Business.

Please Log in or Create an account to join the conversation.

  • Posts: 573
  • Thank you received: 24
  • Hikashop Essential
3 weeks 6 days ago #331741

Ah ok sorry for my confusion on the levels...

The other issue I'm having, with those red highlighted items that I initially thought were caused by a Google outage from what I found last night are still persistent. Further searching seems to be a JavaScript issue. Any thoughts on those as both are now happening again on my site, but at one point the Orders area did show up again but disappeared this morning and is showing the error again.

Please Log in or Create an account to join the conversation.

  • Posts: 72763
  • Thank you received: 11096
  • MODERATOR
3 weeks 6 days ago #331742

Please Log in or Create an account to join the conversation.

  • Posts: 573
  • Thank you received: 24
  • Hikashop Essential
3 weeks 6 days ago #331748

Fantastic...thank you. Guess I didn't search far enough.

I'll get the new one downloaded & update the site tonight.

Please Log in or Create an account to join the conversation.

  • Posts: 573
  • Thank you received: 24
  • Hikashop Essential
3 weeks 6 days ago #331760

Nicolas...that worked, the errors are gone...but there is 1 display issue. Please see the attached image.

When selecting filtering options for the orders, the box is slim and stretched vertically rather than horizontally. I tried both full screen and mobile sized windows. The mobile sized window, the option box switched to horizontal...but at a certain point when you stretch the browner window to a wider screen...that option box switched to vertical like as shown.

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 3175
  • Thank you received: 418
  • MODERATOR
3 weeks 5 days ago #331765

Hello,

Thanks for your return, this will allow us to correct on backend file css for our futur release.
On your side, we will show you how to correct this point, follow me step by step :
1. Have a look on this tutorial to see how to edit the css file, but take care to edit the Back-end Css file.

2. And add at the end of your file this command :

div#hikashop_main_content.hika_j3 #hikashop_listing_filters_id div#filter_status_chzn {
    width: 100% !important;
}

Note : that here the "!important" is unfortunately required in order to override the chosen dropdown inline css.
Hope this will fix your issue.

Regards

Last edit: 3 weeks 5 days ago by Philip.

Please Log in or Create an account to join the conversation.

  • Posts: 573
  • Thank you received: 24
  • Hikashop Essential
3 weeks 4 days ago #331801

Hello Philip...that worked well, thank you very much sir.

The following user(s) said Thank You: Philip

Please Log in or Create an account to join the conversation.

Time to create page: 0.126 seconds
Powered by Kunena Forum