United States Postal Service (USPS) Module

  • Posts: 18
  • Thank you received: 0
8 years 1 month ago #50602

Mike2001,

You are our Hero!

I had already changed the weight symbols, but had the weight set to ounces. When I changed it to pounds, it worked! Not sure why ounces didn't, maybe it's a hierarchy thing, but the problem is solved!

I compared the rates calculated with those from the USPS website and they are spot on.

Mike (if that is your real name), Thank you, thank you, thank you!

Where can I send you a box of chocolates? No, really.

Best,

-John... and Patty;-)

Please Log in or Create an account to join the conversation.

  • Posts: 28
  • Thank you received: 2
8 years 1 month ago #50648

I am glad that worked for you. Make sure you look at my earlier post where I changed an int statement to float. Otherwise you will get an incorrect first class shipping price on very small products.

Mike

Please Log in or Create an account to join the conversation.

  • Posts: 28
  • Thank you received: 2
8 years 1 month ago #50667

For anyone else in the USA looking for Zip Code validation of the user's entry can look at the following post:

www.hikashop.com/en/forum/3-bug-report/4...-needed-auspost.html

Nicolas also provides the code for the US in that post...


Mike

The following user(s) said Thank You: nicolas

Please Log in or Create an account to join the conversation.

  • Posts: 47
  • Thank you received: 1
8 years 4 weeks ago #52565

Is the above link the latest downloadable mod for the USPS? Or can I get the Latest version of the USPS module?

Thanks.

Dave

Last edit: 8 years 4 weeks ago by davemalton.

Please Log in or Create an account to join the conversation.

  • Posts: 69940
  • Thank you received: 10476
  • MODERATOR
8 years 4 weeks ago #52632

Please Log in or Create an account to join the conversation.

  • Posts: 7
  • Thank you received: 0
8 years 2 weeks ago #53987

I have a new site using Joomla 1.6 and HikaShop 1.5.8. I have used the USPS Plugin and it have everything configured. The USPS shipping is not showing up. The manual shipping I have set up is working fine. The USPS shipping method is not even showing up in the Shipping Metods in the Payment Methods files. Is it possible that the Plugin might not work with the newer version? I have used it on Joomla 1.5.25 with HikaShop 1.5.5 and it works fine. Any suggestions?

Thanks!

Please Log in or Create an account to join the conversation.

  • Posts: 12401
  • Thank you received: 1713
  • MODERATOR
8 years 2 weeks ago #54040

Hello,

the USPS plugin is working fine in the Hikashop 1.5.8 version for me, so can you please follow the FAQ and tell me if it works ? :)

Last edit: 8 years 2 weeks ago by Mohamed Thelji.

Please Log in or Create an account to join the conversation.

  • Posts: 4
  • Thank you received: 0
8 years 5 days ago #55728

Hello,

I have installed the USPS shipping method for my client. I plan on shipping to United States and Canada. From what I have researched, I believe I should set zones on my shipping method, one zone for US and another for Canada. But there doesn't seem to be any way to add more than one zone to the USPS module.

I know I can do away with zones entirely, but I don't want to ship to the whole world. Is there a way to limit shipping to just a couple countries?

Thanks,
Zack

Please Log in or Create an account to join the conversation.

  • Posts: 12401
  • Thank you received: 1713
  • MODERATOR
8 years 5 days ago #55732

Hello Zack,

You should :
- Go to "Hikashop->System->Zone->new"
- Create a new Zone
- Save one time
- Add the countries
- Save another time :)
- Go to the USPS plugin page
- Add the zone that you created

Hope this will help you a little.

Last edit: 8 years 5 days ago by Mohamed Thelji.
The following user(s) said Thank You: CSDude

Please Log in or Create an account to join the conversation.

  • Posts: 4
  • Thank you received: 0
8 years 5 days ago #55736

Thanks for your quick reply.

I had actually tried adding a custom zone before. It didn't solve the problem.

Actually, the custom zone did work for the US. But in testing a Canada address, I got the "No shipping methods available to your location" message. I am wondering if it could be that I am not using a valid Canada address.

Do you know how USPS determines a customer's location? For addresses outside the US, does it take into account only the country and state? Or does the zip code also play a role (which means I couldn't just change the country to Canada)?

Please Log in or Create an account to join the conversation.

  • Posts: 69940
  • Thank you received: 10476
  • MODERATOR
8 years 5 days ago #55775

You can't limit the USPS plugin like that.
The way the plugin has been done (by a 3rd party developer) is that the zone you enter in the plugin must be the country from which you're shipping your goods. And it doesn't have any restrictive purpose.

The following user(s) said Thank You: CSDude

Please Log in or Create an account to join the conversation.

  • Posts: 4
  • Thank you received: 0
8 years 5 days ago #55831

Nicolas,

So, I am shipping my goods from within the US. I want to ship to US and Canada. Are you saying I have only two options: (1) use US for the zone (therefore excluding Canada), or (2) use no zone (therefore including the rest of the world)?

If I cannot limit the USPS plugin, is there any way (perhaps a separate module) to restrict orders from outside the US and Canada?

Thanks for your time.

Please Log in or Create an account to join the conversation.

  • Posts: 28
  • Thank you received: 2
8 years 5 days ago #55838

All you need to do is disable every country (and state) other than the US and Canada (in the Zones configuration).

That is what I did. You will also need to make a decision on whether to ship to US outlying areas like the Virgin Islands. You can disable those too. If they do not show up in the address drop down the customer can not select them. This is why it works...

Hope this helps...

The following user(s) said Thank You: CSDude

Please Log in or Create an account to join the conversation.

  • Posts: 4
  • Thank you received: 0
8 years 5 days ago #55844

Thanks Mike! I didn't think about unpublishing the zones.

After unpublishing all other country zones, I've removed the zone from the USPS shipping method. But customers are now limited to choosing only US and Canada when entering their addresses.

This workaround should be sufficient. Thanks for your help.

Please Log in or Create an account to join the conversation.

  • Posts: 29
  • Thank you received: 0
7 years 8 months ago #70164

I Can't get USPS to show up into the payments method as a shipping method :( . And the when I select the shipping method in my cart it says that I have to configure the shipping methods. Any idea.

Last edit: 7 years 8 months ago by provisualusa.

Please Log in or Create an account to join the conversation.

  • Posts: 69940
  • Thank you received: 10476
  • MODERATOR
7 years 8 months ago #70172

Please Log in or Create an account to join the conversation.

  • Posts: 29
  • Thank you received: 0
7 years 8 months ago #70186

OK go it working thanks for that. I don't get any errors for USPS plugin it's great.
The only issue that I have right now is with the UPS shipping method:

Error while sending XML to UPS. Error code: 113021. Message: The Ship To postal code is invalid for the selected location.

This is for Puerto Rico address only. Can you help me please. Thanks in advanced

Please Log in or Create an account to join the conversation.

  • Posts: 29
  • Thank you received: 0
7 years 8 months ago #70189

Sorry allow me to correct my self:
This is the issue that I have:
There's a cross-reference error between USPS and UPS:

The problem is that for UPS Puerto Rico is a country and for USPS Puerto Rico is an State....So:

If someone select the Address let's say: Country = Puerto Rico then the State is blank = USPS error, but UPS works fine

then

If someone select the Address let's say: Country = United State then the State is PR (Puerto Rico)= USP error, but USPS works fine

I don't know if there's a work around to make UPS ignore Puerto Rico when calculate the shipping so I don't get the UPS XML error of country missing.

Thank you in advanced.

Please Log in or Create an account to join the conversation.

  • Posts: 29
  • Thank you received: 0
7 years 8 months ago #70195

No ideas so far? :dry:

Please Log in or Create an account to join the conversation.

  • Posts: 69940
  • Thank you received: 10476
  • MODERATOR
7 years 8 months ago #70372

If you use both shipping methods at the same time and unpublish one of the two zones, then one shipping method won't display for Puerto Rico but the other will display and there won't be any error message displayed.

Please Log in or Create an account to join the conversation.

Time to create page: 0.134 seconds
Powered by Kunena Forum